Bug 230062 - [ macOS wk1 ] fast/text/FontFaceSet-check-after-style-update.html is a flaky failure
Summary: [ macOS wk1 ] fast/text/FontFaceSet-check-after-style-update.html is a flaky ...
Status: RESOLVED DUPLICATE of bug 229975
Alias: None
Product: WebKit
Classification: Unclassified
Component: Text (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2021-09-08 13:49 PDT by ayumi_kojima
Modified: 2021-09-08 17:40 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ayumi_kojima 2021-09-08 13:49:33 PDT
fast/text/FontFaceSet-check-after-style-update.html

Is flaky failing on macOS wk1, mainly on release, but the flaky failure is also seen on BigSur debug.

History: https://results.webkit.org/?suite=layout-tests&test=fast%2Ftext%2FFontFaceSet-check-after-style-update.html

Result page: https://build.webkit.org/results/Apple-BigSur-Release-WK1-Tests/r282110%20(5143)/results.html

Diff:

--- /Volumes/Data/worker/bigsur-release-tests-wk1/build/layout-test-results/fast/text/FontFaceSet-check-after-style-update-expected.txt
+++ /Volumes/Data/worker/bigsur-release-tests-wk1/build/layout-test-results/fast/text/FontFaceSet-check-after-style-update-actual.txt
@@ -5,9 +5,10 @@
 
 PASS fonts.check('12px ThisIsNotARealFont') is true
 PASS fonts.check('12px WebFont') is false
-PASS fonts.check('12px WebFont') is false
+FAIL fonts.check('12px WebFont') should be false. Was true.
 PASS fonts.check('12px WebFont') is true
 PASS successfullyParsed is true
+Some tests failed.
 
 TEST COMPLETE
Comment 1 Radar WebKit Bug Importer 2021-09-08 13:51:43 PDT
<rdar://problem/82889952>
Comment 2 ayumi_kojima 2021-09-08 13:55:39 PDT
Marked test expectations https://trac.webkit.org/changeset/282169/webkit
Comment 3 ayumi_kojima 2021-09-08 14:00:57 PDT
Looking at the history, it looks like the test has been flaky since it was added at https://trac.webkit.org/changeset/282016/webkit
Comment 4 Myles C. Maxfield 2021-09-08 17:40:08 PDT

*** This bug has been marked as a duplicate of bug 229975 ***