https://webkit-search.igalia.com/webkit/source/LayoutTests/imported/w3c/web-platform-tests/inert/inert-node-is-unselectable.tentative.html
Created attachment 437020 [details] Patch
Created attachment 437021 [details] Patch
Created attachment 437022 [details] Patch
Created attachment 437036 [details] Patch
Comment on attachment 437036 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=437036&action=review > Source/WebCore/dom/Position.cpp:945 > bool Position::nodeIsUserSelectNone(Node* node) > { > - return node && node->renderer() && node->renderer()->style().userSelect() == UserSelect::None; > + if (!node) > + return false; > + if (node->isInert()) > + return true; > + return node->renderer() && node->renderer()->style().userSelect() == UserSelect::None; > } The name of the function no longer matches what it does ("nodeIsInertOrUserSelectNone"). How about renaming it to something more accurate?
Created attachment 437156 [details] Patch
Committed r281930 (241239@main): <https://commits.webkit.org/241239@main> All reviewed patches have been landed. Closing bug and clearing flags on attachment 437156 [details].
<rdar://problem/82679366>