RESOLVED FIXED Bug 229082
Unprefix -webkit-mask and longhand forms
https://bugs.webkit.org/show_bug.cgi?id=229082
Summary Unprefix -webkit-mask and longhand forms
Sam Sneddon [:gsnedders]
Reported 2021-08-13 10:47:24 PDT
For some of these the value keywords have changed (e.g. from margin to margin-box), and notably Chrome doesn't yet support it prefixed. Nevertheless, Firefox does support the unprefixed form and there are a (small) number of WPT tests that rely on this.
Attachments
Work in progress patch (122.60 KB, patch)
2021-11-17 14:22 PST, Simon Fraser (smfr)
no flags
Patch (415.97 KB, patch)
2021-11-24 17:40 PST, Matt Woodrow
no flags
Patch (16.01 KB, patch)
2021-11-25 13:14 PST, Matt Woodrow
no flags
Patch (441.68 KB, patch)
2021-11-25 16:25 PST, Matt Woodrow
no flags
Patch (461.39 KB, patch)
2021-11-28 14:16 PST, Matt Woodrow
no flags
Patch (456.10 KB, patch)
2021-12-08 11:52 PST, Matt Woodrow
no flags
Patch (457.26 KB, patch)
2021-12-08 19:19 PST, Matt Woodrow
no flags
Radar WebKit Bug Importer
Comment 1 2021-08-20 10:48:46 PDT
Simon Fraser (smfr)
Comment 2 2021-10-21 11:11:35 PDT
I have a patch for part of this.
Simon Fraser (smfr)
Comment 3 2021-11-17 14:22:45 PST
Created attachment 444576 [details] Work in progress patch
Matt Woodrow
Comment 4 2021-11-24 17:40:24 PST
Matt Woodrow
Comment 5 2021-11-25 13:14:37 PST
Matt Woodrow
Comment 6 2021-11-25 16:25:27 PST
Matt Woodrow
Comment 7 2021-11-28 14:16:42 PST
Antti Koivisto
Comment 8 2021-12-07 04:44:59 PST
Comment on attachment 445242 [details] Patch looks like you need to do some more rebasing
Antti Koivisto
Comment 9 2021-12-07 04:59:21 PST
Comment on attachment 445242 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=445242&action=review > Source/WebCore/css/CSSComputedStyleDeclaration.cpp:4458 > +size_t ComputedStyleExtractor::getLayerCount(CSSPropertyID property) > +{ > + ASSERT(property == CSSPropertyBackground || property == CSSPropertyMask); > + if (!styledElement()) > + return 0; I already see this code in trunk so I suppose it is not really part of this change? We don't start function names with 'get', this should be called layerCount/countLayers/countLayersForProperty or similar. There are functions in this file that don't follow the rule, that's not a reason to add new code like that. Also some of them are like that because they are exposed in CSSOM. > Source/WebCore/css/CSSComputedStyleDeclaration.cpp:4476 > +Ref<CSSValueList> ComputedStyleExtractor::getFillLayerPropertyShorthandValue(CSSPropertyID property, const StylePropertyShorthand& propertiesBeforeSlashSeparator, const StylePropertyShorthand& propertiesAfterSlashSeparator, CSSPropertyID lastLayerProperty) > +{ > + ASSERT(property == CSSPropertyBackground || property == CSSPropertyMask); > + size_t layerCount = getLayerCount(property); This too
Matt Woodrow
Comment 10 2021-12-08 11:52:51 PST
Matt Woodrow
Comment 11 2021-12-08 19:19:41 PST
EWS
Comment 12 2021-12-09 12:23:50 PST
Committed r286795 (245035@main): <https://commits.webkit.org/245035@main> All reviewed patches have been landed. Closing bug and clearing flags on attachment 446485 [details].
Brent Fulgham
Comment 13 2022-07-13 15:05:50 PDT
*** Bug 121432 has been marked as a duplicate of this bug. ***
Tim Nguyen (:ntim)
Comment 14 2023-08-29 23:49:22 PDT
*** Bug 137294 has been marked as a duplicate of this bug. ***
Tim Nguyen (:ntim)
Comment 15 2023-08-29 23:49:42 PDT
*** Bug 137292 has been marked as a duplicate of this bug. ***
Note You need to log in before you can comment on or make changes to this bug.