Bug 22899 - HTMLAnchorElement.pathname returns decoded attribute
Summary: HTMLAnchorElement.pathname returns decoded attribute
Status: RESOLVED DUPLICATE of bug 30225
Alias: None
Product: WebKit
Classification: Unclassified
Component: HTML DOM (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Erik Arvidsson
URL: http://home.react.nl/~michiel/webkit-...
Keywords:
Depends on:
Blocks:
 
Reported: 2008-12-17 02:47 PST by Michiel Roding
Modified: 2011-10-06 13:22 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michiel Roding 2008-12-17 02:47:18 PST
If an anchor's href contains encoded characters, reading the anchor's pathname returns a decoded path.

Firefox and IE return the 'raw' version (thus with %.. in the string) whereas webkit returns a decoded path. Opera returns a decoded path as well.

As a sidenote, IE6 returns a decoded href-attribute as well.

I assume that fetching the attribute of an element returns the actual value, not a modified value.
Comment 1 Dan POPA 2009-07-23 23:26:11 PDT
This issue reproduces in Safari 3 and 4 on Mac and Win.
It doesn't reproduce in Chrome 2.0.172.37 and 3.0.193.2.
Comment 2 Erik Arvidsson 2011-10-06 13:22:20 PDT
Fixed in http://trac.webkit.org/changeset/96779

*** This bug has been marked as a duplicate of bug 30225 ***