Bug 228824 - WebKit::SampleBufferDisplayLayer needs to handle GPUProcess crash
Summary: WebKit::SampleBufferDisplayLayer needs to handle GPUProcess crash
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebRTC (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: youenn fablet
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2021-08-05 06:44 PDT by youenn fablet
Modified: 2021-08-06 12:04 PDT (History)
9 users (show)

See Also:


Attachments
Patch (11.60 KB, patch)
2021-08-05 06:49 PDT, youenn fablet
no flags Details | Formatted Diff | Diff
Patch (14.90 KB, patch)
2021-08-05 10:51 PDT, youenn fablet
ews-feeder: commit-queue-
Details | Formatted Diff | Diff
Patch (15.96 KB, patch)
2021-08-06 03:03 PDT, youenn fablet
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description youenn fablet 2021-08-05 06:44:53 PDT
WebKit::SampleBufferDisplayLayer needs to handle GPUProcess crash
Comment 1 Radar WebKit Bug Importer 2021-08-05 06:45:17 PDT
<rdar://problem/81564477>
Comment 2 youenn fablet 2021-08-05 06:49:34 PDT
Created attachment 434982 [details]
Patch
Comment 3 Eric Carlson 2021-08-05 09:27:59 PDT
Comment on attachment 434982 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=434982&action=review

> Source/WebCore/platform/graphics/avfoundation/objc/MediaPlayerPrivateMediaStreamAVFObjC.mm:341
> +    destroyLayers();
> +    updateLayersAsNeeded();

There are three status values: "unknown", "rendering", and "failed".  Do we really want to destroy the layers every time the status changes?
Comment 4 youenn fablet 2021-08-05 09:52:15 PDT
Good point, we should rename it to sampleBufferDisplayLayerStatusFailed.
Comment 5 youenn fablet 2021-08-05 09:52:30 PDT
And only call it when rendering fails.
Comment 6 Peng Liu 2021-08-05 10:14:38 PDT
Comment on attachment 434982 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=434982&action=review

> Source/WebCore/ChangeLog:3
> +        WebKit::SampleBufferDisplayLayer needs to handle GPUProcess crash

Will this patch fix bug 228759?
Comment 7 youenn fablet 2021-08-05 10:51:22 PDT
Created attachment 435005 [details]
Patch
Comment 8 youenn fablet 2021-08-06 03:03:12 PDT
Created attachment 435061 [details]
Patch
Comment 9 youenn fablet 2021-08-06 04:15:55 PDT
(In reply to Peng Liu from comment #6)
> Comment on attachment 434982 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=434982&action=review
> 
> > Source/WebCore/ChangeLog:3
> > +        WebKit::SampleBufferDisplayLayer needs to handle GPUProcess crash
> 
> Will this patch fix bug 228759?

No, bug 228759 is due to an unrelated regression
Comment 10 EWS 2021-08-06 12:04:25 PDT
Committed r280731 (240318@main): <https://commits.webkit.org/240318@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 435061 [details].