WebKit Bugzilla
New
Browse
Log In
×
Sign in with GitHub
or
Remember my login
Create Account
·
Forgot Password
Forgotten password account recovery
RESOLVED FIXED
228224
[GPU Process] Start tracking resource uses for NativeImages and Fonts
https://bugs.webkit.org/show_bug.cgi?id=228224
Summary
[GPU Process] Start tracking resource uses for NativeImages and Fonts
Myles C. Maxfield
Reported
2021-07-23 00:40:26 PDT
[GPU Process] Start tracking resource uses for NativeImages and Fonts
Attachments
Patch for reviewing
(18.43 KB, patch)
2021-07-23 00:45 PDT
,
Myles C. Maxfield
no flags
Details
Formatted Diff
Diff
Patch for EWS
(30.90 KB, patch)
2021-07-23 00:46 PDT
,
Myles C. Maxfield
no flags
Details
Formatted Diff
Diff
Patch
(15.88 KB, patch)
2021-07-26 21:04 PDT
,
Myles C. Maxfield
no flags
Details
Formatted Diff
Diff
Patch
(16.10 KB, patch)
2021-07-27 13:34 PDT
,
Myles C. Maxfield
sabouhallawa
: review+
ews-feeder
: commit-queue-
Details
Formatted Diff
Diff
Show Obsolete
(3)
View All
Add attachment
proposed patch, testcase, etc.
Myles C. Maxfield
Comment 1
2021-07-23 00:45:09 PDT
Created
attachment 434070
[details]
Patch for reviewing
Myles C. Maxfield
Comment 2
2021-07-23 00:46:41 PDT
Created
attachment 434071
[details]
Patch for EWS
Myles C. Maxfield
Comment 3
2021-07-26 21:04:36 PDT
Created
attachment 434267
[details]
Patch
Myles C. Maxfield
Comment 4
2021-07-27 13:34:09 PDT
Created
attachment 434309
[details]
Patch
Said Abou-Hallawa
Comment 5
2021-07-27 13:52:30 PDT
Comment on
attachment 434309
[details]
Patch View in context:
https://bugs.webkit.org/attachment.cgi?id=434309&action=review
> Source/WebCore/platform/graphics/displaylists/DisplayListReplayer.cpp:105 > + if (delegate) {
Maybe an early return will look clearer if (!delegate) return std::nullopt;
> Source/WebCore/platform/graphics/displaylists/DisplayListReplayer.cpp:108 > + if (changeFlags.contains(GraphicsContextState::StrokePatternChange)) > + delegate->recordResourceUse(strokePatternRenderingResourceIdentifier);
Can't this be written like this: if (strokePatternRenderingResourceIdentifier) delegate->recordResourceUse(strokePatternRenderingResourceIdentifier);
> Source/WebKit/WebProcess/GPU/graphics/RemoteResourceCacheProxy.cpp:81 > void RemoteResourceCacheProxy::cacheNativeImage(NativeImage& image)
Maybe we need to choose new names for these functions since they do more than just caching the resources: cacheNativeImageAndUse() ensureNativeImageIsCachedAndUse() recordNativeImageUse() Or something similar. This may be also done in a separate patch.
Myles C. Maxfield
Comment 6
2021-07-27 15:51:59 PDT
Comment on
attachment 434309
[details]
Patch View in context:
https://bugs.webkit.org/attachment.cgi?id=434309&action=review
>> Source/WebCore/platform/graphics/displaylists/DisplayListReplayer.cpp:108 >> + delegate->recordResourceUse(strokePatternRenderingResourceIdentifier); > > Can't this be written like this: > > if (strokePatternRenderingResourceIdentifier) > delegate->recordResourceUse(strokePatternRenderingResourceIdentifier);
We can! Good catch.
>> Source/WebKit/WebProcess/GPU/graphics/RemoteResourceCacheProxy.cpp:81 >> void RemoteResourceCacheProxy::cacheNativeImage(NativeImage& image) > > Maybe we need to choose new names for these functions since they do more than just caching the resources: > > cacheNativeImageAndUse() > ensureNativeImageIsCachedAndUse() > recordNativeImageUse() > > Or something similar. This may be also done in a separate patch.
Yeah, this is a good idea. I'll do this in a follow-up patch.
Myles C. Maxfield
Comment 7
2021-07-27 15:53:05 PDT
Committed
r280356
(
240003@main
): <
https://commits.webkit.org/240003@main
>
Radar WebKit Bug Importer
Comment 8
2021-07-27 15:54:26 PDT
<
rdar://problem/81186859
>
Myles C. Maxfield
Comment 9
2021-07-27 16:09:04 PDT
Comment on
attachment 434309
[details]
Patch View in context:
https://bugs.webkit.org/attachment.cgi?id=434309&action=review
>>> Source/WebKit/WebProcess/GPU/graphics/RemoteResourceCacheProxy.cpp:81 >>> void RemoteResourceCacheProxy::cacheNativeImage(NativeImage& image) >> >> Maybe we need to choose new names for these functions since they do more than just caching the resources: >> >> cacheNativeImageAndUse() >> ensureNativeImageIsCachedAndUse() >> recordNativeImageUse() >> >> Or something similar. This may be also done in a separate patch. > > Yeah, this is a good idea. I'll do this in a follow-up patch.
https://bugs.webkit.org/show_bug.cgi?id=228495
Note
You need to
log in
before you can comment on or make changes to this bug.
Top of Page
Format For Printing
XML
Clone This Bug