Bug 228216 - ☂️ [GPU Process] Defer removal of resources in the GPU Process until we've executed all display list items which reference them
Summary: ☂️ [GPU Process] Defer removal of resources in the GPU Process until we've ex...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Myles C. Maxfield
URL:
Keywords: InRadar
: 227881 (view as bug list)
Depends on: 228224 228225 228495
Blocks:
  Show dependency treegraph
 
Reported: 2021-07-22 20:15 PDT by Myles C. Maxfield
Modified: 2021-08-12 13:52 PDT (History)
3 users (show)

See Also:


Attachments
WIP (30.34 KB, patch)
2021-07-22 20:19 PDT, Myles C. Maxfield
no flags Details | Formatted Diff | Diff
WIP (32.51 KB, patch)
2021-07-22 21:19 PDT, Myles C. Maxfield
no flags Details | Formatted Diff | Diff
First draft (37.03 KB, patch)
2021-07-22 21:41 PDT, Myles C. Maxfield
no flags Details | Formatted Diff | Diff
Patch (4.69 KB, patch)
2021-07-28 15:36 PDT, Myles C. Maxfield
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Myles C. Maxfield 2021-07-22 20:15:49 PDT
[GPU Process] Defer removal of resources in the GPU Process until we've executed all display list items which reference them
Comment 1 Myles C. Maxfield 2021-07-22 20:19:58 PDT
Created attachment 434059 [details]
WIP
Comment 2 Myles C. Maxfield 2021-07-22 21:19:06 PDT
Created attachment 434062 [details]
WIP
Comment 3 Myles C. Maxfield 2021-07-22 21:41:30 PDT
Created attachment 434063 [details]
First draft
Comment 4 Myles C. Maxfield 2021-07-23 01:20:31 PDT
1. https://bugs.webkit.org/show_bug.cgi?id=228219 [GPU Process] Migrate the DisplayList::Replayer::Delegate from RemoteImageBuffer to RemoteRenderingBackend
2. https://bugs.webkit.org/show_bug.cgi?id=228222 [GPU Process] Add resource use counter infrastructure to RemoteResourceCache
3. https://bugs.webkit.org/show_bug.cgi?id=228224 [GPU Process] Start tracking resource uses for NativeImages and Fonts
4. https://bugs.webkit.org/show_bug.cgi?id=228225 [GPU Process] Start tracking resource uses for ImageBuffers
Comment 5 Myles C. Maxfield 2021-07-23 01:21:43 PDT
<rdar://problem/80473805>
Comment 6 Myles C. Maxfield 2021-07-26 21:14:19 PDT
I guess this can be the bug that I use to remove all the TestExpectation lines
Comment 7 Myles C. Maxfield 2021-07-28 15:35:47 PDT
*** Bug 227881 has been marked as a duplicate of this bug. ***
Comment 8 Myles C. Maxfield 2021-07-28 15:36:42 PDT
Created attachment 434473 [details]
Patch
Comment 9 Wenson Hsieh 2021-07-28 17:09:45 PDT
Comment on attachment 434473 [details]
Patch

r=mews
Comment 10 EWS 2021-07-29 01:32:24 PDT
Committed r280418 (240058@main): <https://commits.webkit.org/240058@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 434473 [details].