Bug 227925 - [iOS & Mac Big Sur Release] Two SOAuthorizationSubFrame API tests are failing
Summary: [iOS & Mac Big Sur Release] Two SOAuthorizationSubFrame API tests are failing
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Brent Fulgham
URL:
Keywords: InRadar
Depends on: 227729
Blocks: 227974
  Show dependency treegraph
 
Reported: 2021-07-13 15:47 PDT by ayumi_kojima
Modified: 2021-07-14 17:53 PDT (History)
6 users (show)

See Also:


Attachments
Patch (2.45 KB, patch)
2021-07-14 16:43 PDT, Brent Fulgham
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description ayumi_kojima 2021-07-13 15:47:57 PDT
TestWebKitAPI.SOAuthorizationSubFrame.SOAuthorizationLoadPolicyIgnore
TestWebKitAPI.SOAuthorizationSubFrame.SOAuthorizationLoadPolicyIgnoreAsync

Are failing on iOS 14 E Simulator Release on iPhone 8 and iPad Pro. There seems to be a flaky crash on Big Sur Release on iMac and iOS 14 E Simulator Debug on iPhone 8 as well.

History: https://results.webkit.org/?suite=api-tests&suite=api-tests&test=TestWebKitAPI.SOAuthorizationSubFrame.SOAuthorizationLoadPolicyIgnore&test=TestWebKitAPI.SOAuthorizationSubFrame.SOAuthorizationLoadPolicyIgnoreAsync

=====================================

TestWebKitAPI.SOAuthorizationSubFrame.SOAuthorizationLoadPolicyIgnore
        
        /Volumes/Data/worker/ios-simulator-14-release/build/Tools/TestWebKitAPI/Tests/WebKitCocoa/TestSOAuthorization.mm:2586
        Value of: policyForAppSSOPerformed
          Actual: true
        Expected: false
        
TestWebKitAPI.SOAuthorizationSubFrame.SOAuthorizationLoadPolicyIgnoreAsync
        
        /Volumes/Data/worker/ios-simulator-14-release/build/Tools/TestWebKitAPI/Tests/WebKitCocoa/TestSOAuthorization.mm:2643
        Value of: policyForAppSSOPerformed
          Actual: true
        Expected: false

=====================================

https://build.webkit.org/#/builders/28/builds/2401/steps/12/logs/stdio
Comment 1 Radar WebKit Bug Importer 2021-07-13 16:10:59 PDT
<rdar://problem/80543830>
Comment 2 ayumi_kojima 2021-07-13 16:12:05 PDT
I was not able to reproduce the failure on my local machine using run-api-tests TestWebKitAPI.SOAuthorizationSubFrame.SOAuthorizationLoadPolicyIgnore --ios-simulator
Comment 3 Ryan Haddad 2021-07-13 16:12:22 PDT
Probably related to https://trac.webkit.org/changeset/279755/webkit
Comment 4 Brent Fulgham 2021-07-13 16:24:47 PDT
Both of these test cases load apple.com in an iframe. They have a hard-coded 0.5s timeout, which might be insufficient to consistently get the assertion right.
Comment 5 Brent Fulgham 2021-07-14 16:43:03 PDT
Created attachment 433543 [details]
Patch
Comment 6 Kate Cheney 2021-07-14 16:46:32 PDT
Comment on attachment 433543 [details]
Patch

r=me

Should we file a bug to track adding them back?
Comment 7 Brent Fulgham 2021-07-14 16:57:00 PDT
(In reply to Kate Cheney from comment #6)
> Comment on attachment 433543 [details]
> Patch
> 
> r=me
> 
> Should we file a bug to track adding them back?

I filed Bug 227974 to do so.
Comment 8 EWS 2021-07-14 17:53:54 PDT
Committed r279935 (239679@main): <https://commits.webkit.org/239679@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 433543 [details].