Bug 22656 - tests document.write()
Summary: tests document.write()
Status: RESOLVED DUPLICATE of bug 32755
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P4 Minor
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-12-04 12:10 PST by Danish Shrestha
Modified: 2010-04-26 19:10 PDT (History)
2 users (show)

See Also:


Attachments
patch for testing document.write (906 bytes, patch)
2008-12-04 12:11 PST, Danish Shrestha
darin: review-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Danish Shrestha 2008-12-04 12:10:17 PST
This patch tests that document.write() with no parameters does not output any text.
Comment 1 Danish Shrestha 2008-12-04 12:11:01 PST
Created attachment 25746 [details]
patch for testing document.write
Comment 2 Darin Adler 2008-12-04 16:01:35 PST
Comment on attachment 25746 [details]
patch for testing document.write

This test looks fine, but the patch needs to also include a ChangeLog entry. Also, we prefer to have the "newline at end of file" unless there's a reason not to have it.

Also, we prefer tests that cover a bit more per test. It's OK to have a test that tests only this one targeted thing, but it's better to cover more per test so our tests cover a lot of different cases and run quickly.
Comment 3 Joseph Pecoraro 2010-04-26 15:34:43 PDT
It looks like testing an empty document.write is now covered by:

    LayoutTests/fast/forms/document-write-empty.html

The Git/SVN/Trac History of this file seems to be confused:
http://trac.webkit.org/browser/trunk/LayoutTests/fast/forms/document-write-empty.html?rev=58265

The content is essentially identical, and the test's description is verbatim! I don't really know what is best, so I'm closing this as "Works For Me" because there is now a test. I'd mark it a duplicate, but I can't accurately find the original bug.
Comment 4 Alexey Proskuryakov 2010-04-26 19:10:56 PDT

*** This bug has been marked as a duplicate of bug 32755 ***