Bug 225526 - [ BigSur Release wk2 ARM64 ] http/tests/misc/repeat-open-cancel.html is a flaky timeout
Summary: [ BigSur Release wk2 ARM64 ] http/tests/misc/repeat-open-cancel.html is a fla...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Chris Gambrell
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2021-05-07 11:26 PDT by Robert Jenner
Modified: 2021-10-01 16:09 PDT (History)
5 users (show)

See Also:


Attachments
Patch (1.44 KB, patch)
2021-05-24 10:15 PDT, Chris Gambrell
cgambrell: review?
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Jenner 2021-05-07 11:26:02 PDT
http/tests/misc/repeat-open-cancel.html

is a flaky timeout on BigSur Release wk2 on Apple Silicon Macs only.

HISTORY:
https://results.webkit.org/?suite=layout-tests&test=http%2Ftests%2Fmisc%2Frepeat-open-cancel.html&platform=mac

TIMEOUT DIFF:
-This is a test for https://bugs.webkit.org/show_bug.cgi?id=191650.
+#PID UNRESPONSIVE - WebKitTestRunner (pid 91164)
+FAIL: Timed out waiting for notifyDone to be called
 
-In case that several requests are closed and created pretty fast, a result of old request sometimes goes to a wrong request.
-
-PASS
+#EOF
+#EOF
https://build.webkit.org/results/Apple-BigSur-Release-AppleSilicon-WK2-Tests/r277174%20(1348)/http/tests/misc/repeat-open-cancel-pretty-diff.html
Comment 1 Robert Jenner 2021-05-07 15:03:45 PDT
This is only occurring on Apple Silicon Macs. As such, I cannot reproduce the timeout because I do not have access to said system. 

Updated expectations to Pass Timeout here:
https://trac.webkit.org/changeset/277204/webkit
Comment 2 Radar WebKit Bug Importer 2021-05-07 15:04:14 PDT
<rdar://problem/77674900>
Comment 3 Chris Gambrell 2021-05-24 10:11:38 PDT
After inspecting it appears as though this issue has resolved itself. Updating TestExpectations
Comment 4 Chris Gambrell 2021-05-24 10:15:29 PDT
Created attachment 429543 [details]
Patch
Comment 5 ayumi_kojima 2021-10-01 14:09:53 PDT
Removed the expectation at Bug 231088 by updating it for a new bug https://trac.webkit.org/changeset/283399/webkit
Comment 6 ayumi_kojima 2021-10-01 16:09:07 PDT
(In reply to ayumi_kojima from comment #5)
> Removed the expectation at Bug 231088 by updating it for a new bug
> https://trac.webkit.org/changeset/283399/webkit

It is Bug 231097 not Bug 231088.