Bug 22544 - TinyMCE editor not working properly in Safari 3.1 or 4b
Summary: TinyMCE editor not working properly in Safari 3.1 or 4b
Status: RESOLVED DUPLICATE of bug 21382
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-11-28 07:13 PST by chriskresser
Modified: 2019-05-02 16:23 PDT (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description chriskresser 2008-11-28 07:13:13 PST
When I highlight text within a comment and then click on the "link" button to create a hyperlink within the TinyMCE text editor, the box that pops up where I'm supposed to enter the link URL is completely blank.  I've confirmed this problem is with WebKit browsers, because it works perfectly well in Firefox and Camino.  I also contacted the webmaster of one website that uses the TinyMCE editor, and he confirmed that it is a known issue that Safari is not compatible with this feature.
Comment 1 Cameron Zwarich (cpst) 2008-11-29 01:16:02 PST
This works fine for me in both Safari 3.2.1 and ToT WebKit on

http://tinymce.moxiecode.com/examples/full.php#

However, inserting an anchor, which works in Safari 3.2.1, is problematic in ToT WebKit.

Can you please give steps for reproducing this with a particular site?

Comment 2 chriskresser 2008-11-29 07:17:56 PST
(In reply to comment #1)
> This works fine for me in both Safari 3.2.1 and ToT WebKit on
> 
> http://tinymce.moxiecode.com/examples/full.php#
> 
> However, inserting an anchor, which works in Safari 3.2.1, is problematic in
> ToT WebKit.
> 
> Can you please give steps for reproducing this with a particular site?
> 

Thanks for your reply. Unfortunately, I do not think you'll be able to reproduce the bug without signing up for a free account on the website in question so that you are able to post comments.  

If you are willing to do that, please go to http://chrismartenson.com.  Create a free account.  When finished, click on the headline of any of the recent blog posts.  At the bottom is the comments form.  Once there:

1. Write something in the comment box.
2. Select (highlight) the text.
3. Click the "link" button in the TinyMCE text editor toolbar (it looks like a "chain")
4. A box will pop-up for you to enter the link URL - but it will be blank!  

The blank box is the bug I'm trying to report.  The webmaster confirmed that other Safari Mac users (not sure about Safari PC users) have the exact same problem.

Furthermore, when I use Firefox or Camino with this website and follow the steps above, the "link" button works properly and I am able to enter the link URL in the pop-up box.

Thanks for your help with this.  
Comment 3 chriskresser 2008-11-29 07:20:57 PST
P.S. Safari does work properly with the link you gave me.  I noticed that is the "full" TinyMCE editor with all of the options, while the TinyMCE editor used on chrismartenson.com seems to be a paired-down version.  Not sure if that matters.
Comment 4 Robert Blaut 2008-12-27 13:54:56 PST

*** This bug has been marked as a duplicate of 21382 ***
Comment 6 Paul 2017-10-14 14:38:50 PDT
Get access to live codes and also grab the best hacking tool for PSN games online. This is amazing as this can make you all happy. Now get some, and explore more.Get some amazing console today for free. This real and authentic. Get some real experience of playing PSN games online. I am so thankful for the website PSN Codes. I am going to share this with everyone.  As it is very interesting my friends are also looking for it, I am gonna share it with them instantly.This is the website which can generate PSN codes, from the generator available on the mentioned website. I used this generator when I had a PlayStation 3 and I am using it again with my Playstation 4 and it works like a charm. If you do not get $100 code, just try $50, $20 or $10. I Have got so many codes and can advance in the game with ease...Now I am gaming all the time with my friends and enjoy it to the fullest. I am so thankful to the website. I am going to share this with everyone.  As it is very interesting my friends are also looking for it, I am gonna share it with them instantly.
http://www.generaccion.com/usuarios/139551/get-free-psn-codes-no-survey-no-human-verification
Comment 7 Pauls Stalker 2017-10-25 16:03:04 PDT
Finally, NBA live Mobile game has arrived and gamers must not waste a moment to hit the court with the most amazing basketball game ever produced till date. NBA live Mobile is a special gift for the all basketball lovers who follow NBA events and think of owning a strong team that will dominate the opponents. This game is from the same team of madden mobile inventors. This particular mobile game offers you a wonderful opportunity to stay connected with NBA live events all year along with an amazing 5-on-5 action. With your efforts and skills, it is very much possible to capture the spotlight and construct a team to beat in the competitive world of basketball. There is a lot to know about the game but we would mainly like to focus on best possible ways to attain coins and cash. If you have been part of the game for a while, you would be completely aware of the need to get many coins and cash in order to build a strong team and add legend players. Surely, there are certain ways to do the job but the most effective one is to use NBA Live Mobile Hack And Cheats.

http://www.emailmeform.com/builder/form/qf8aNTsUpdA7
Comment 8 sri 2017-11-14 08:05:45 PST
Thanks for posting.
free psn codes no survey has related links which has playstation and its codes
http://www.freepsncodesnosurvey.club/
Comment 9 Pauls Stalker 2018-06-28 13:15:20 PDT
We are a very thankful admin for sharing such wonderful stuff. With your permission, I also want to share some cool stuff regarding PlayStation Store Codes. Everybody likes to share experience on Facebook but they don't have or get a specific idea about Free PSN Codes. So nothing to worry to get Free PSN Codes No Human Verification we have a blog. Source- https://paulstalker007.wixsite.com/paulsidea/single-post/free-psn-code-no-survey-no-human-verification