Bug 225400 - Remove obsolete media query values
Summary: Remove obsolete media query values
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Tim Nguyen (:ntim)
URL:
Keywords: InRadar
: 225414 (view as bug list)
Depends on:
Blocks: update-css-wpt
  Show dependency treegraph
 
Reported: 2021-05-05 11:45 PDT by Tim Nguyen (:ntim)
Modified: 2021-05-06 11:03 PDT (History)
16 users (show)

See Also:


Attachments
Patch (62.31 KB, patch)
2021-05-05 14:18 PDT, Tim Nguyen (:ntim)
no flags Details | Formatted Diff | Diff
Patch (66.06 KB, patch)
2021-05-05 17:16 PDT, Tim Nguyen (:ntim)
no flags Details | Formatted Diff | Diff
Patch (66.03 KB, patch)
2021-05-05 23:40 PDT, Tim Nguyen (:ntim)
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Nguyen (:ntim) 2021-05-05 11:45:55 PDT
It's redundant with the forced-colors media query which is why it's been removed from the spec.

No other browser ships it.
Comment 1 Radar WebKit Bug Importer 2021-05-05 11:50:09 PDT
<rdar://problem/77568034>
Comment 2 Tim Nguyen (:ntim) 2021-05-05 13:44:38 PDT
Also taking care of any-hover: on-demand & hover: on-demand which have been removed too: https://github.com/w3c/csswg-drafts/commit/2078b46218f7462735bb0b5107c9a3e84fb4c4b1
Comment 3 Tim Nguyen (:ntim) 2021-05-05 14:18:29 PDT
Created attachment 427806 [details]
Patch
Comment 4 Myles C. Maxfield 2021-05-05 15:31:31 PDT
In general, we don't remove web-exposed functionality because there's a chance it will break existing content.

Do we have any intuition/information about how much breakage to expect as a result of this change?
Comment 5 Tim Nguyen (:ntim) 2021-05-05 16:47:05 PDT
There's no behaviour change in terms of evaluation, before and after the patch, it'll always evaluate as `not all` (e.g. false). 

Only change is serialization, now that the values are invalid, they'll no longer serialize as specified, but explicitly as `not all`. Serialization is probably the least important bit of media queries, WPT are probably the only case I've seen doing this.
Comment 6 Tim Nguyen (:ntim) 2021-05-05 17:16:16 PDT
Created attachment 427825 [details]
Patch
Comment 7 Tim Nguyen (:ntim) 2021-05-05 23:40:09 PDT
Created attachment 427852 [details]
Patch
Comment 8 Tim Nguyen (:ntim) 2021-05-06 00:19:59 PDT
*** Bug 225414 has been marked as a duplicate of this bug. ***
Comment 9 EWS 2021-05-06 00:36:37 PDT
Committed r277071 (237374@main): <https://commits.webkit.org/237374@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 427852 [details].
Comment 11 Truitt Savell 2021-05-06 11:03:23 PDT
Filed: https://bugs.webkit.org/show_bug.cgi?id=225469