Bug 223717 - Do not do process pre-warming when the system is under memory pressure
Summary: Do not do process pre-warming when the system is under memory pressure
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Chris Dumez
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2021-03-24 16:29 PDT by Chris Dumez
Modified: 2021-03-26 16:17 PDT (History)
7 users (show)

See Also:


Attachments
Patch (4.24 KB, patch)
2021-03-24 16:41 PDT, Chris Dumez
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Dumez 2021-03-24 16:29:52 PDT
Do not do process pre-warming when the system is under memory pressure.

We already avoid launching prewarmed processes when the system is under memory pressure. However, this really only works as intended on iOS because we're not listening for all the memory pressure notification on macOS.
Also, we should return early in WebProcess::prewarmGlobally() if the system is under memory pressure now that the process has been launched.
Comment 1 Radar WebKit Bug Importer 2021-03-24 16:30:25 PDT
<rdar://problem/75810423>
Comment 2 Chris Dumez 2021-03-24 16:41:19 PDT
Created attachment 424199 [details]
Patch
Comment 3 EWS 2021-03-25 09:49:52 PDT
Committed r275038: <https://commits.webkit.org/r275038>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 424199 [details].