Bug 222274 - REGRESSION(r273204): webkitpy tests don't run on Py3
Summary: REGRESSION(r273204): webkitpy tests don't run on Py3
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P1 Normal
Assignee: Sam Sneddon [:gsnedders]
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2021-02-22 09:31 PST by Sam Sneddon [:gsnedders]
Modified: 2021-02-22 11:56 PST (History)
2 users (show)

See Also:


Attachments
Patch (1.55 KB, patch)
2021-02-22 09:34 PST, Sam Sneddon [:gsnedders]
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sam Sneddon [:gsnedders] 2021-02-22 09:31:22 PST
gsnedders@gsnedders-milk py-bisect % ./Tools/Scripts/test-webkitpy
Suppressing most webkitpy logging while running unit tests.
Skipping tests in the following modules or packages because they are really, really, slow:
    webkitpy.common.checkout.scm.scm_unittest
    (https://bugs.webkit.org/show_bug.cgi?id=31818; use --all to include)

Checking imports ...Failed to import webkit.messages_unittest:
Failed to import webkit.messages_unittest:
  Traceback (most recent call last):
  Traceback (most recent call last):
    File "/Volumes/gsnedders/projects/Safari/py-bisect/Tools/Scripts/webkitpy/test/main.py", line 290, in _check_imports
    File "/Volumes/gsnedders/projects/Safari/py-bisect/Tools/Scripts/webkitpy/test/main.py", line 290, in _check_imports
      __import__(name)
      __import__(name)
    File "/Volumes/gsnedders/projects/Safari/py-bisect/Source/WebKit/Scripts/webkit/messages_unittest.py", line 36, in <module>
    File "/Volumes/gsnedders/projects/Safari/py-bisect/Source/WebKit/Scripts/webkit/messages_unittest.py", line 36, in <module>
      from webkit import messages, model, parser  # noqa: E402
      from webkit import messages, model, parser  # noqa: E402
    File "/Volumes/gsnedders/projects/Safari/py-bisect/Source/WebKit/Scripts/webkit/messages.py", line 27, in <module>
    File "/Volumes/gsnedders/projects/Safari/py-bisect/Source/WebKit/Scripts/webkit/messages.py", line 27, in <module>
      from model import MessageReceiver, Message
      from model import MessageReceiver, Message
  ModuleNotFoundError: No module named 'model'
  ModuleNotFoundError: No module named 'model'
Comment 1 Sam Sneddon [:gsnedders] 2021-02-22 09:34:32 PST
Created attachment 421203 [details]
Patch
Comment 2 EWS 2021-02-22 11:55:50 PST
Committed r273266: <https://commits.webkit.org/r273266>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 421203 [details].
Comment 3 Radar WebKit Bug Importer 2021-02-22 11:56:13 PST
<rdar://problem/74607169>