Bug 22183 - Crashes in Leopard build bot in LayoutTests/storage and LayoutTests/fast/js/exceptions-thrown-in-callbacks.html
Summary: Crashes in Leopard build bot in LayoutTests/storage and LayoutTests/fast/js/e...
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
: 22184 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-11-11 13:14 PST by Pierre-Olivier Latour
Modified: 2009-07-31 15:35 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pierre-Olivier Latour 2008-11-11 13:14:39 PST
For some time, there has been 10 crashes in the Leopard build bot in LayoutTests/storage:
http://build.webkit.org/results/trunk-mac-intel-pixel/197/results.html
Comment 1 Pierre-Olivier Latour 2008-11-11 16:47:13 PST
Here's the backtrace (apparently the same for all crashes):

Exception Type:  EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000000
Crashed Thread:  0

Thread 0 Crashed:
0   libSystem.B.dylib             	0x92efcd9e pthread_mutex_lock + 18
1   com.apple.WebCore             	0x01455061 WebCore::guidForOriginAndName(WebCore::String const&, WebCore::String const&) + 529 (Database.cpp:368)
2   com.apple.WebCore             	0x01455347 WebCore::Database::Database(WebCore::Document*, WebCore::String const&, WebCore::String const&) + 375 (Database.cpp:135)
3   com.apple.WebCore             	0x0145667b WebCore::Database::openDatabase(WebCore::Document*, WebCore::String const&, WebCore::String const&, WebCore::String const&, unsigned long, int&) + 123 (Database.cpp:101)
4   com.apple.WebCore             	0x0144eb1f WebCore::DOMWindow::openDatabase(WebCore::String const&, WebCore::String const&, WebCore::String const&, unsigned long, int&) + 143 (DOMWindow.cpp:814)
5   com.apple.WebCore             	0x015f8e88 WebCore::jsDOMWindowPrototypeFunctionOpenDatabase(JSC::ExecState*, JSC::JSObject*, JSC::JSValue*, JSC::ArgList const&) + 664 (JSDOMWindow.cpp:4230)

Thread 1:
0   libSystem.B.dylib             	0x92ef54a6 mach_msg_trap + 10
1   libSystem.B.dylib             	0x92efcc9c mach_msg + 72
2   com.apple.CoreFoundation      	0x92cc00ce CFRunLoopRunSpecific + 1790
3   com.apple.CoreFoundation      	0x92cc0cf8 CFRunLoopRunInMode + 88
4   com.apple.CFNetwork           	0x948aaeca CFURLCacheWorkerThread(void*) + 396
5   libSystem.B.dylib             	0x92f266f5 _pthread_start + 321
6   libSystem.B.dylib             	0x92f265b2 thread_start + 34

Thread 2:
0   libSystem.B.dylib             	0x92ef54a6 mach_msg_trap + 10
1   libSystem.B.dylib             	0x92efcc9c mach_msg + 72
2   com.apple.CoreFoundation      	0x92cc00ce CFRunLoopRunSpecific + 1790
3   com.apple.CoreFoundation      	0x92cc0cf8 CFRunLoopRunInMode + 88
4   com.apple.Foundation          	0x913cf100 +[NSURLConnection(NSURLConnectionReallyInternal) _resourceLoadLoop:] + 320
5   com.apple.Foundation          	0x9136bbad -[NSThread main] + 45
6   com.apple.Foundation          	0x9136b754 __NSThread__main__ + 308
7   libSystem.B.dylib             	0x92f266f5 _pthread_start + 321
8   libSystem.B.dylib             	0x92f265b2 thread_start + 34

Thread 3:
0   libSystem.B.dylib             	0x92f455e2 select$DARWIN_EXTSN + 10
1   libSystem.B.dylib             	0x92f266f5 _pthread_start + 321
2   libSystem.B.dylib             	0x92f265b2 thread_start + 34

Thread 0 crashed with X86 Thread State (32-bit):
  eax: 0x00000000  ebx: 0x92efcd9d  ecx: 0x00000000  edx: 0x00000000
  edi: 0x00000000  esi: 0x16ed4180  ebp: 0xbfffdc18  esp: 0xbfffdbe0
   ss: 0x0000001f  efl: 0x00010282  eip: 0x92efcd9e   cs: 0x00000017
   ds: 0x0000001f   es: 0x0000001f   fs: 0x00000000   gs: 0x00000037
  cr2: 0x00000000


Comment 2 Pierre-Olivier Latour 2008-11-11 16:47:41 PST
*** Bug 22184 has been marked as a duplicate of this bug. ***
Comment 3 Pierre-Olivier Latour 2008-11-11 16:48:41 PST
There's a 11th crash with the same backtrace here:
LayoutTests/fast/js/exceptions-thrown-in-callbacks.html
Comment 4 Simon Fraser (smfr) 2008-11-11 16:48:51 PST
This looks a bit like one of Greg's:

    static Mutex& stringIdentifierMutex = *new Mutex;
...
    static HashMap<String, int>& stringIdentifierToGUIDMap = *new HashMap<String, int>;
Comment 5 Greg Bolsinga 2008-11-11 16:51:13 PST
I'll pretty sure this is covered by the latest patch in Bug 21810.
Comment 6 Simon Fraser (smfr) 2008-11-11 16:53:00 PST
Darin committed that. It's related to bug 22061 and bug 22061. I'm guessing we're seeing the same compiler issue discussed in 21810.
Comment 7 Greg Bolsinga 2009-07-30 12:54:33 PDT
Is this applicable anymore?
Comment 8 Greg Bolsinga 2009-07-31 15:23:29 PDT
I do not see LayoutTests/storage nor LayoutTests/fast/js/exceptions-thrown-in-callbacks.html in today's Mac Leopard skip list, so these tests are now successfully running.

So this can be closed.