Bug 22061 - create script to check for exit-time destructors
: create script to check for exit-time destructors
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: Tools / Tests
: 528+ (Nightly build)
: Macintosh Mac OS X 10.5
: P2 Normal
Assigned To: Darin Adler
:
Depends on:
Blocks: 21810
  Show dependency treegraph
 
Reported: 2008-11-03 18:16 PST by Darin Adler
Modified: 2008-11-04 11:28 PST (History)
1 user (show)

See Also:


Attachments
patch (48.23 KB, patch)
2008-11-03 18:25 PST, Darin Adler
timothy: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Darin Adler 2008-11-03 18:16:21 PST
We'd like to eliminate all exit-time destructors from WebKit for faster process exit.
Comment 1 Darin Adler 2008-11-03 18:25:08 PST
Created attachment 24876 [details]
patch
Comment 2 Timothy Hatcher 2008-11-04 05:26:59 PST
Comment on attachment 24876 [details]
patch

> +void lockAtomicallyInitializedStaticMutex() {}
> +void unlockAtomicallyInitializedStaticMutex() { }

Space between the braces vs no space in the previous function.

> +    static String& key =  *new String("WebKitDatabaseVersionKey");

Extra space between the assignment.

r=me
Comment 3 Greg Bolsinga 2008-11-04 11:09:56 PST
I think this fixes Bug 21810
Comment 4 Greg Bolsinga 2008-11-04 11:11:44 PST
*** Bug 21810 has been marked as a duplicate of this bug. ***
Comment 5 Darin Adler 2008-11-04 11:19:59 PST
(In reply to comment #3)
> I think this fixes Bug 21810

No, it doesn't fix it. It's just the tool to help us track the additional work needed.