Bug 214889 - Migrate App-Bound Domains code from WebKit Additions
Summary: Migrate App-Bound Domains code from WebKit Additions
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Misc. (show other bugs)
Version: WebKit Local Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: katherine_cheney
URL:
Keywords: InRadar
Depends on: 214917
Blocks:
  Show dependency treegraph
 
Reported: 2020-07-28 12:24 PDT by katherine_cheney
Modified: 2020-07-29 15:24 PDT (History)
5 users (show)

See Also:


Attachments
Patch (34.51 KB, patch)
2020-07-28 13:20 PDT, katherine_cheney
no flags Details | Formatted Diff | Diff
Patch (34.59 KB, patch)
2020-07-28 13:25 PDT, katherine_cheney
no flags Details | Formatted Diff | Diff
Patch (34.59 KB, patch)
2020-07-28 13:40 PDT, katherine_cheney
no flags Details | Formatted Diff | Diff
Patch (34.62 KB, patch)
2020-07-28 13:48 PDT, katherine_cheney
no flags Details | Formatted Diff | Diff
Patch (34.87 KB, patch)
2020-07-28 13:54 PDT, katherine_cheney
no flags Details | Formatted Diff | Diff
Patch (35.26 KB, patch)
2020-07-28 14:01 PDT, katherine_cheney
no flags Details | Formatted Diff | Diff
Patch (35.02 KB, patch)
2020-07-28 14:05 PDT, katherine_cheney
no flags Details | Formatted Diff | Diff
Patch (173.19 KB, patch)
2020-07-28 14:27 PDT, katherine_cheney
no flags Details | Formatted Diff | Diff
Patch (43.19 KB, patch)
2020-07-28 15:01 PDT, katherine_cheney
no flags Details | Formatted Diff | Diff
Patch for landing (35.69 KB, patch)
2020-07-28 15:49 PDT, katherine_cheney
no flags Details | Formatted Diff | Diff
Patch (38.43 KB, patch)
2020-07-29 11:11 PDT, katherine_cheney
no flags Details | Formatted Diff | Diff
Patch (36.36 KB, patch)
2020-07-29 12:27 PDT, katherine_cheney
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description katherine_cheney 2020-07-28 12:24:36 PDT
We should migrate some additional app-bound domains code to WebKit
Comment 1 katherine_cheney 2020-07-28 12:25:05 PDT
rdar://problem/66075857
Comment 2 katherine_cheney 2020-07-28 13:20:53 PDT
Created attachment 405399 [details]
Patch
Comment 3 katherine_cheney 2020-07-28 13:25:27 PDT
Created attachment 405400 [details]
Patch
Comment 4 katherine_cheney 2020-07-28 13:40:06 PDT
Created attachment 405402 [details]
Patch
Comment 5 katherine_cheney 2020-07-28 13:48:47 PDT
Created attachment 405405 [details]
Patch
Comment 6 katherine_cheney 2020-07-28 13:54:45 PDT
Created attachment 405406 [details]
Patch
Comment 7 katherine_cheney 2020-07-28 14:01:13 PDT
Created attachment 405409 [details]
Patch
Comment 8 katherine_cheney 2020-07-28 14:05:37 PDT
Created attachment 405411 [details]
Patch
Comment 9 katherine_cheney 2020-07-28 14:06:12 PDT
Having some trouble making EWS happy, hopefully this one does it...
Comment 10 katherine_cheney 2020-07-28 14:27:19 PDT
Created attachment 405414 [details]
Patch
Comment 11 katherine_cheney 2020-07-28 15:01:52 PDT
Created attachment 405419 [details]
Patch
Comment 12 Brent Fulgham 2020-07-28 15:33:06 PDT
Comment on attachment 405419 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=405419&action=review

r=me, but please correct the ChangeLog that includes Ryan's description, too.

> Source/WebKit/Shared/Cocoa/DefaultWebBrowserChecks.mm:192
> +        @"NSRemindersUsageDescription",

Can you please remove the "NSRemindersUsageDescription", we are not restricting this one anymore.

> LayoutTests/ChangeLog:11
> +

Oops! Two ChangeLog entries.
Comment 13 katherine_cheney 2020-07-28 15:39:36 PDT
(In reply to Brent Fulgham from comment #12)
> Comment on attachment 405419 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=405419&action=review
> 
> r=me, but please correct the ChangeLog that includes Ryan's description, too.
> 

Whoops -- accidentally absorbed that along the way. Will fix.

> > Source/WebKit/Shared/Cocoa/DefaultWebBrowserChecks.mm:192
> > +        @"NSRemindersUsageDescription",
> 

Yes, will do.

> Can you please remove the "NSRemindersUsageDescription", we are not
> restricting this one anymore.
> 
> > LayoutTests/ChangeLog:11
> > +
> 
> Oops! Two ChangeLog entries.

Good catch!
Comment 14 katherine_cheney 2020-07-28 15:49:30 PDT
Created attachment 405422 [details]
Patch for landing
Comment 15 EWS 2020-07-28 16:14:14 PDT
Committed r265018: <https://trac.webkit.org/changeset/265018>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 405422 [details].
Comment 16 Aakash Jain 2020-07-29 04:51:42 PDT
This (In reply to EWS from comment #15)
> Committed r265018: <https://trac.webkit.org/changeset/265018>
This seems to have broken various ios-wk2 tests. Tracked in Bug 214916. 

Please make sure to run the patches through EWS before landing. In this case there were 10 patches uploaded within ~2 hours, and none of the patches were run through ios-wk2, api-ios, mac-debug-wk1, win EWSes.
Comment 17 WebKit Commit Bot 2020-07-29 04:52:54 PDT
Re-opened since this is blocked by bug 214917
Comment 18 katherine_cheney 2020-07-29 11:11:34 PDT
Created attachment 405476 [details]
Patch
Comment 19 katherine_cheney 2020-07-29 11:12:33 PDT
Thanks Aakash -- my bad on not letting EWS finish. I am unable to reproduce these failures locally, so I am uploading this patch with some logging to try and figure out what is going on on EWS.
Comment 20 katherine_cheney 2020-07-29 12:27:28 PDT
Created attachment 405484 [details]
Patch
Comment 21 Brent Fulgham 2020-07-29 15:16:50 PDT
Comment on attachment 405484 [details]
Patch

r=me
Comment 22 EWS 2020-07-29 15:24:25 PDT
Committed r265063: <https://trac.webkit.org/changeset/265063>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 405484 [details].