Bug 21474 - WebKit r37381 crashing
Summary: WebKit r37381 crashing
Status: CLOSED DUPLICATE of bug 21459
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Mac OS X 10.5
: P2 Major
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-10-08 09:13 PDT by Michael Jerome
Modified: 2008-10-11 08:03 PDT (History)
0 users

See Also:


Attachments
Crash report from WebKit on OSX (23.28 KB, text/plain)
2008-10-09 02:39 PDT, Michael Jerome
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Jerome 2008-10-08 09:13:42 PDT
Hi.  If you visit http://www.startupsplus.co.uk then click around on the navigation ('home', 'testimonials', 'news' etc) the browser totally crashes and needs relaunching.

I can't replicate the issue using Safari 3.1 so must assume it is a web kit issue.

As the browser crashes, I don't know how to go about reducing the problem more accurately.
Comment 1 Mark Rowe (bdash) 2008-10-08 14:30:42 PDT
Please attach a crash log: http://webkit.org/quality/crashlogs.html.
Comment 2 Michael Jerome 2008-10-09 02:35:10 PDT
I believe the issue is to do with JavaScript so have updated component.  If I disable JavaScript the browser does not crash.
Comment 3 Michael Jerome 2008-10-09 02:39:33 PDT
Created attachment 24229 [details]
Crash report from WebKit on OSX

Crash report
Comment 4 Cameron Zwarich (cpst) 2008-10-09 17:32:07 PDT
This is a duplicate of bug 21459 and was fixed in r37450.

*** This bug has been marked as a duplicate of 21459 ***
Comment 5 Michael Jerome 2008-10-11 08:03:11 PDT
Confirmed the bug is FIXED in r37469.