Bug 213993 - getUserMedia() Camera not rotating with iPad when it's upside down
Summary: getUserMedia() Camera not rotating with iPad when it's upside down
Status: RESOLVED DUPLICATE of bug 211373
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebRTC (show other bugs)
Version: Safari 13
Hardware: iPhone / iPad iOS 13
: P2 Minor
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2020-07-06 08:29 PDT by Andrew
Modified: 2020-07-10 13:13 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew 2020-07-06 08:29:09 PDT
Current Behaviour/Bug:
When I rotate my iPad, the video feed from getUserMedia() only rotates itself when it's in landscape left, landscape right, or portrait, not when its upside down.

Expected Behaviour:
When I rotate my iPad, no matter the orientation, the video feed from getUserMedia() should respect whatever orientation it's in.

You can see this bug here: https://webrtc.github.io/samples/src/content/getusermedia/gum/

Device: iPad Mini 4
iOS Version: 13.3.1

Thanks so much!
Comment 1 Radar WebKit Bug Importer 2020-07-07 18:42:54 PDT
<rdar://problem/65203301>
Comment 2 Eric Carlson 2020-07-10 13:13:14 PDT
This was fixed in r261080

*** This bug has been marked as a duplicate of bug 211373 ***