Bug 212279 - Revoking an object URL immediately after triggering navigation causes navigation to fail
Summary: Revoking an object URL immediately after triggering navigation causes navigat...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Chris Dumez
URL:
Keywords: InRadar
: 211234 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-05-22 13:55 PDT by Chris Dumez
Modified: 2020-05-22 15:50 PDT (History)
8 users (show)

See Also:


Attachments
Patch (7.59 KB, patch)
2020-05-22 14:22 PDT, Chris Dumez
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Dumez 2020-05-22 13:55:34 PDT
Revoking an object URL immediately after triggering navigation causes navigation to fail.
Comment 1 Radar WebKit Bug Importer 2020-05-22 13:56:58 PDT
<rdar://problem/63553090>
Comment 2 Chris Dumez 2020-05-22 14:22:44 PDT
Created attachment 400076 [details]
Patch
Comment 3 Chris Dumez 2020-05-22 14:24:13 PDT
*** Bug 211234 has been marked as a duplicate of this bug. ***
Comment 4 Geoffrey Garen 2020-05-22 14:25:56 PDT
Comment on attachment 400076 [details]
Patch

r=me
Comment 5 EWS 2020-05-22 15:50:54 PDT
Committed r262085: <https://trac.webkit.org/changeset/262085>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 400076 [details].