Bug 211587 - REGRESSION(r260959): "Causes MiniBrowser to crash when closing a window" (Requested by ddkilzer on #webkit).
Summary: REGRESSION(r260959): "Causes MiniBrowser to crash when closing a window" (Req...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: WebKit Commit Bot
URL:
Keywords: InRadar
: 211586 (view as bug list)
Depends on:
Blocks: 211243
  Show dependency treegraph
 
Reported: 2020-05-07 11:55 PDT by WebKit Commit Bot
Modified: 2020-05-07 12:13 PDT (History)
4 users (show)

See Also:


Attachments
REVERT of r260959 (1.60 KB, patch)
2020-05-07 11:55 PDT, WebKit Commit Bot
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description WebKit Commit Bot 2020-05-07 11:55:18 PDT
https://trac.webkit.org/changeset/260959 broke the build:
"Causes MiniBrowser to crash when closing a window" (Requested by ddkilzer on #webkit).

This is an automatic bug report generated by webkitbot. If this bug
report was created because of a flaky test, please file a bug for the flaky
test (if we don't already have one on file) and dup this bug against that bug
so that we can track how often these flaky tests fail.
Comment 1 WebKit Commit Bot 2020-05-07 11:55:22 PDT
Created attachment 398772 [details]
REVERT of r260959

Any committer can land this patch automatically by marking it commit-queue+.  The commit-queue will build and test the patch before landing to ensure that the revert will be successful.  This process takes approximately 15 minutes.

If you would like to land the revert faster, you can use the following command:

  webkit-patch land-attachment ATTACHMENT_ID

where ATTACHMENT_ID is the ID of this attachment.
Comment 2 David Kilzer (:ddkilzer) 2020-05-07 11:56:24 PDT
*** Bug 211586 has been marked as a duplicate of this bug. ***
Comment 3 David Kilzer (:ddkilzer) 2020-05-07 11:57:52 PDT
Waiting for builds to complete before marking cq+.
Comment 4 David Kilzer (:ddkilzer) 2020-05-07 12:11:42 PDT
Comment on attachment 398772 [details]
REVERT of r260959

Marking cq+ as 'mac' build succeeded.
Comment 5 EWS 2020-05-07 12:12:34 PDT
Committed r261324: <https://trac.webkit.org/changeset/261324>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 398772 [details].
Comment 6 Radar WebKit Bug Importer 2020-05-07 12:13:15 PDT
<rdar://problem/62987570>