Bug 211484 - [WebGL2] webgl/2.0.0/conformance[2]/textures/image_bitmap* failures
Summary: [WebGL2] webgl/2.0.0/conformance[2]/textures/image_bitmap* failures
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebGL (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P1 Normal
Assignee: Kenneth Russell
URL:
Keywords: InRadar
Depends on: 208875
Blocks: 126404 182424 189641 216565 183438
  Show dependency treegraph
 
Reported: 2020-05-05 20:02 PDT by Kenneth Russell
Modified: 2020-09-17 18:39 PDT (History)
19 users (show)

See Also:


Attachments
Patch (1003.27 KB, patch)
2020-08-02 15:11 PDT, Kenneth Russell
no flags Details | Formatted Diff | Diff
Patch (1004.66 KB, patch)
2020-08-02 15:41 PDT, Kenneth Russell
no flags Details | Formatted Diff | Diff
Patch (1004.72 KB, patch)
2020-08-03 09:18 PDT, Kenneth Russell
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kenneth Russell 2020-05-05 20:02:40 PDT
There are several failures in each test underneath webgl/2.0.0/conformance2/textures/image_bitmap_from_canvas/ . Initial triage indicates the failures might be caused by WebKit not respecting the premultiplyAlpha option to createImageBitmap, but it's not clear.

To reduce the size of subsequent texture-related rebaselines, these tests are being skipped for the time being. The failures will need to be investigated before the WebGL 2.0 conformance suite can be passed.
Comment 1 Kenneth Russell 2020-07-30 11:00:50 PDT
The image_bitmap_from_blob, image_bitmap_from_image and image_bitmap_from_video tests are all failing for the same reason - WebKit doesn't yet implement the imageOrientation or premultiplyAlpha ImageBitmapOptions:

https://html.spec.whatwg.org/multipage/imagebitmap-and-animations.html

This is core functionality and is a blocker for conformance - raising to P1, and assigning to dino@ per recent discussion on Slack.

Affected test directories:

webgl/2.0.0/conformance[2]/textures/image_bitmap_from_blob/*
webgl/2.0.0/conformance[2]/textures/image_bitmap_from_image/*
webgl/2.0.0/conformance[2]/textures/image_bitmap_from_video/*
Comment 2 Kenneth Russell 2020-07-30 13:25:50 PDT
After further discussion with dino@, taking this bug; will attempt a fix.
Comment 3 Kenneth Russell 2020-08-02 15:11:30 PDT
Created attachment 405813 [details]
Patch
Comment 4 Kenneth Russell 2020-08-02 15:41:05 PDT
Created attachment 405814 [details]
Patch
Comment 5 Kenneth Russell 2020-08-03 09:07:24 PDT
The attached patch implements ImageBitmapOptions' ImageOrientation="flipY" and PremultiplyAlpha="premultiply" options, and makes several dozen tests under:
    webgl/2.0.0/conformance[2]/textures/image_bitmap_from_blob/
    webgl/2.0.0/conformance[2]/textures/image_bitmap_from_canvas/
    webgl/2.0.0/conformance[2]/textures/image_bitmap_from_image/
    webgl/2.0.0/conformance[2]/textures/image_bitmap_from_video/

The bulk of the patch is the rebaseline; the code changes are relatively small.
Comment 6 Kenneth Russell 2020-08-03 09:18:02 PDT
Created attachment 405835 [details]
Patch
Comment 7 EWS 2020-08-03 11:19:11 PDT
Committed r265208: <https://trac.webkit.org/changeset/265208>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 405835 [details].
Comment 8 Radar WebKit Bug Importer 2020-08-03 13:38:26 PDT
<rdar://problem/66489332>