Bug 210252 - Use more PAC diversity for JIT probe code.
Summary: Use more PAC diversity for JIT probe code.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Mark Lam
URL:
Keywords: InRadar
Depends on: 210254 210314
Blocks:
  Show dependency treegraph
 
Reported: 2020-04-09 00:50 PDT by Mark Lam
Modified: 2020-04-16 15:37 PDT (History)
6 users (show)

See Also:


Attachments
work in progress. (9.41 KB, patch)
2020-04-09 02:34 PDT, Mark Lam
no flags Details | Formatted Diff | Diff
proposed patch. (11.17 KB, patch)
2020-04-10 11:25 PDT, Mark Lam
keith_miller: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Lam 2020-04-09 00:50:15 PDT
<rdar://problem/54490367>
Comment 1 Mark Lam 2020-04-09 02:34:53 PDT
Created attachment 395927 [details]
work in progress.
Comment 2 Mark Lam 2020-04-10 11:25:47 PDT
Created attachment 396107 [details]
proposed patch.
Comment 3 Keith Miller 2020-04-10 13:12:55 PDT
Comment on attachment 396107 [details]
proposed patch.

r=me. Can you confirm the failing JSC test isn't related to your patch though?
Comment 4 Mark Lam 2020-04-10 13:21:37 PDT
Thanks for the review.

(In reply to Keith Miller from comment #3)
> Comment on attachment 396107 [details]
> proposed patch.
> 
> r=me. Can you confirm the failing JSC test isn't related to your patch
> though?

The failing test is stress/regress-189028.js.ftl-eager.  It does not reproduce for me locally.  Hence, it's not due to my patch.
Comment 5 Mark Lam 2020-04-10 13:28:09 PDT
Landed in r259897: <http://trac.webkit.org/r259897>.
Comment 6 Mark Lam 2020-04-16 14:41:09 PDT
Rolled out r259897 in r260222: <http://trac.webkit.org/r260222>.
Comment 7 Mark Lam 2020-04-16 15:37:02 PDT
The issue was just a debug ASSERT that does not apply for non-ARM64E builds.

Re-landed in r260223: <http://trac.webkit.org/r260223>.