Bug 209362 - [ iOS wk2 ] animations/animation-direction-reverse.html is a flaky failure
Summary: [ iOS wk2 ] animations/animation-direction-reverse.html is a flaky failure
Status: RESOLVED DUPLICATE of bug 210156
Alias: None
Product: WebKit
Classification: Unclassified
Component: Animations (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2020-03-20 14:38 PDT by Jacob Uphoff
Modified: 2020-04-23 09:46 PDT (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jacob Uphoff 2020-03-20 14:38:14 PDT
animations/animation-direction-reverse.html

This test has been a flaky failure for all visible history for the test on iOS wk2 with debug and release. 

History:

https://results.webkit.org/?suite=layout-tests&test=animations%2Fanimation-direction-reverse.html

Diff:

--- /Volumes/Data/slave/ios-simulator-13-release-tests-wk2/build/layout-test-results/animations/animation-direction-reverse-expected.txt
+++ /Volumes/Data/slave/ios-simulator-13-release-tests-wk2/build/layout-test-results/animations/animation-direction-reverse-actual.txt
@@ -1,4 +1,4 @@
-PASS - "margin-left" property for "box" element at 0.5s saw something close to: 150
-PASS - "margin-left" property for "box" element at 1s saw something close to: 100
+FAIL - "margin-left" property for "box" element at 0.5s expected: 150 but saw: 184.60000610351562
+FAIL - "margin-left" property for "box" element at 1s expected: 100 but saw: 139
 PASS - "margin-left" property for "box" element at 2.5s saw something close to: 0
Comment 1 Radar WebKit Bug Importer 2020-03-20 14:45:52 PDT
<rdar://problem/60705451>
Comment 2 Jacob Uphoff 2020-03-20 15:31:37 PDT
Set expectations here: https://trac.webkit.org/changeset/258794/webkit
Comment 3 Antoine Quint 2020-03-23 09:56:37 PDT

*** This bug has been marked as a duplicate of bug 206671 ***
Comment 4 Antoine Quint 2020-03-23 09:57:51 PDT
Actually, de-duping, the failure is now specific to iOS.
Comment 5 Antoine Quint 2020-04-23 09:46:57 PDT
Fixing this along with bug 210156.

*** This bug has been marked as a duplicate of bug 210156 ***