Bug 206671 - animations/animation-direction-reverse.html is flaky failing
Summary: animations/animation-direction-reverse.html is flaky failing
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Animations (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Antoine Quint
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2020-01-23 09:56 PST by Jacob Uphoff
Modified: 2020-03-23 09:58 PDT (History)
8 users (show)

See Also:


Attachments
Update Test Expectations (2.10 KB, patch)
2020-01-27 17:00 PST, Jacob Uphoff
no flags Details | Formatted Diff | Diff
Patch (4.54 KB, patch)
2020-03-18 07:08 PDT, Antoine Quint
no flags Details | Formatted Diff | Diff
Patch (4.62 KB, patch)
2020-03-18 07:15 PDT, Antoine Quint
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jacob Uphoff 2020-01-23 09:56:51 PST
animations/animation-direction-reverse.html is flaky failing on debug with wk1 and wk2 on macOS and iOS.

I did not try to reproduce the failure.

History:
https://results.webkit.org/?suite=layout-tests&test=animations%2Fanimation-direction-reverse.html

Diff:

--- /Volumes/Data/slave/mojave-debug-tests-wk2/build/layout-test-results/animations/animation-direction-reverse-expected.txt
+++ /Volumes/Data/slave/mojave-debug-tests-wk2/build/layout-test-results/animations/animation-direction-reverse-actual.txt
@@ -1,4 +1,4 @@
-PASS - "webkitTransform" property for "box" element at 0.5s saw something close to: 1,0,0,1,150,0
-PASS - "webkitTransform" property for "box" element at 1s saw something close to: 1,0,0,1,100,0
+FAIL - "webkitTransform" property for "box" element at 0.5s expected: 1,0,0,1,150,0 but saw: matrix(1, 0, 0, 1, 199.6999969482422, 0)
+FAIL - "webkitTransform" property for "box" element at 1s expected: 1,0,0,1,100,0 but saw: matrix(1, 0, 0, 1, 199.6999969482422, 0)
 PASS - "webkitTransform" property for "box" element at 2.5s saw something close to: none
Comment 1 Radar WebKit Bug Importer 2020-01-23 09:57:15 PST
<rdar://problem/58838216>
Comment 2 Jacob Uphoff 2020-01-27 17:00:56 PST
Created attachment 388942 [details]
Update Test Expectations
Comment 3 Truitt Savell 2020-01-27 17:03:54 PST
Comment on attachment 388942 [details]
Update Test Expectations

Clearing flags on attachment: 388942

Committed r255213: <https://trac.webkit.org/changeset/255213>
Comment 4 Antoine Quint 2020-03-18 07:08:47 PDT
Created attachment 393847 [details]
Patch
Comment 5 Antoine Quint 2020-03-18 07:15:43 PDT
Created attachment 393849 [details]
Patch
Comment 6 WebKit Commit Bot 2020-03-18 08:26:55 PDT
Comment on attachment 393849 [details]
Patch

Clearing flags on attachment: 393849

Committed r258634: <https://trac.webkit.org/changeset/258634>
Comment 7 WebKit Commit Bot 2020-03-18 08:26:57 PDT
All reviewed patches have been landed.  Closing bug.
Comment 8 Antoine Quint 2020-03-23 09:56:37 PDT
*** Bug 209362 has been marked as a duplicate of this bug. ***