Bug 208019 - REGRESSION: (r256619) [ Mac wk1 Release ] legacy-animation-engine/fast/animation/animation-mixed-transform-crash.html is flaky failing.
Summary: REGRESSION: (r256619) [ Mac wk1 Release ] legacy-animation-engine/fast/animat...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: WebKit Commit Bot
URL:
Keywords: InRadar
Depends on:
Blocks: 50856
  Show dependency treegraph
 
Reported: 2020-02-20 11:16 PST by WebKit Commit Bot
Modified: 2020-02-24 07:32 PST (History)
7 users (show)

See Also:


Attachments
Archive of layout-test-results from webkit-cq-02 (3.41 MB, application/zip)
2020-02-20 11:16 PST, WebKit Commit Bot
no flags Details
animation-mixed-transform-crash-actual (16.92 KB, image/png)
2020-02-21 11:46 PST, Jason Lawrence
no flags Details
Patch (1.49 KB, patch)
2020-02-24 03:59 PST, Antoine Quint
no flags Details | Formatted Diff | Diff
Patch for landing (2.33 KB, patch)
2020-02-24 07:02 PST, Antoine Quint
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description WebKit Commit Bot 2020-02-20 11:16:41 PST
This is an automatically generated bug from the commit-queue.
legacy-animation-engine/fast/animation/animation-mixed-transform-crash.html has been flaky on the commit-queue.

legacy-animation-engine/fast/animation/animation-mixed-transform-crash.html was authored by graouts@apple.com.
https://trac.webkit.org/browser/trunk/LayoutTests/legacy-animation-engine/fast/animation/animation-mixed-transform-crash.html

The commit-queue just saw legacy-animation-engine/fast/animation/animation-mixed-transform-crash.html flake (image diff) while processing attachment 391294 [details] on bug 208009.
Bot: webkit-cq-02  Port: <class 'webkitpy.common.config.ports.MacPort'>  Platform: Mac OS X 10.14.6

The bots will update this with information from each new failure.

If you believe this bug to be fixed or invalid, feel free to close.  The bots will re-open if the flake re-occurs.

If you would like to track this test fix with another bug, please close this bug as a duplicate.  The bots will follow the duplicate chain when making future comments.
Comment 1 WebKit Commit Bot 2020-02-20 11:16:42 PST
Created attachment 391311 [details]
Archive of layout-test-results from webkit-cq-02
Comment 2 Jason Lawrence 2020-02-21 11:46:08 PST
Created attachment 391415 [details]
animation-mixed-transform-crash-actual
Comment 3 Jason Lawrence 2020-02-21 11:48:07 PST
legacy-animation-engine/fast/animation/animation-mixed-transform-crash.html

Description:
This test is flaky failing on Mac wk1 Release. The percentage and images linked in the diffs are different, issue appears to have regressed with r256764.

History:
https://results.webkit.org/?suite=layout-tests&test=legacy-animation-engine%2Ffast%2Fanimation%2Fanimation-mixed-transform-crash.html&platform=mac&flavor=wk1&limit=50000&style=release

Diff:
Attached.
https://build.webkit.org/results/Apple%20Mojave%20Release%20WK1%20(Tests)/r256764%20(11645)/legacy-animation-engine/fast/animation/animation-mixed-transform-crash-diffs.html
Comment 4 Radar WebKit Bug Importer 2020-02-21 11:48:30 PST
<rdar://problem/59676811>
Comment 5 Jason Lawrence 2020-02-21 11:59:50 PST
I have marked this test as failing while the issue is investigated.
https://trac.webkit.org/changeset/257154/webkit
Comment 6 Jason Lawrence 2020-02-21 12:15:26 PST
I am able to reproduce this issue on a r257137 using the command below.

Run-webkit-tests legacy-animation-engine/fast/animation/animation-mixed-transform-crash.html --iterations 4000 --exit-after-n-failures 5 -f --force --platform mac-mojave -1
[9/4000] legacy-animation-engine/fast/animation/animation-mixed-transform-crash.html failed unexpectedly (reference mismatch)
[27/4000] legacy-animation-engine/fast/animation/animation-mixed-transform-crash.html failed unexpectedly (reference mismatch)
[31/4000] legacy-animation-engine/fast/animation/animation-mixed-transform-crash.html failed unexpectedly (reference mismatch)
[62/4000] legacy-animation-engine/fast/animation/animation-mixed-transform-crash.html failed unexpectedly (reference mismatch)
[69/4000] legacy-animation-engine/fast/animation/animation-mixed-transform-crash.html failed unexpectedly (reference mismatch)
Exiting early after 5 failures. 66 tests run.
61 tests ran as expected, 5 didn't (3934 didn't run):

r256763:
[8/4000] legacy-animation-engine/fast/animation/animation-mixed-transform-crash.html failed unexpectedly (reference mismatch)
[9/4000] legacy-animation-engine/fast/animation/animation-mixed-transform-crash.html failed unexpectedly (reference mismatch)
[42/4000] legacy-animation-engine/fast/animation/animation-mixed-transform-crash.html failed unexpectedly (reference mismatch)
[46/4000] legacy-animation-engine/fast/animation/animation-mixed-transform-crash.html failed unexpectedly (reference mismatch)
[57/4000] legacy-animation-engine/fast/animation/animation-mixed-transform-crash.html failed unexpectedly (reference mismatch)
Exiting early after 5 failures. 54 tests run.
49 tests ran as expected, 5 didn't (3946 didn't run):
Comment 7 Jason Lawrence 2020-02-21 15:21:06 PST
I am able to reproduce the issue with r256619 using the command below.
run-webkit-tests legacy-animation-engine/fast/animation/animation-mixed-transform-crash.html --iterations 4000 --exit-after-n-failures 5 -f --force --platform mac-mojave -1
[29/4000] legacy-animation-engine/fast/animation/animation-mixed-transform-crash.html failed unexpectedly (reference mismatch)
[70/4000] legacy-animation-engine/fast/animation/animation-mixed-transform-crash.html failed unexpectedly (reference mismatch)
[124/4000] legacy-animation-engine/fast/animation/animation-mixed-transform-crash.html failed unexpectedly (reference mismatch)
[126/4000] legacy-animation-engine/fast/animation/animation-mixed-transform-crash.html failed unexpectedly (reference mismatch)
[147/4000] legacy-animation-engine/fast/animation/animation-mixed-transform-crash.html failed unexpectedly (reference mismatch)
Exiting early after 5 failures. 144 tests run.
139 tests ran as expected, 5 didn't (3856 didn't run):

I cannot reproduce the issue on r256618 using this command:
run-webkit-tests legacy-animation-engine/fast/animation/animation-mixed-transform-crash.html --iterations 4000 --exit-after-n-failures 5 -f --force --platform mac-mojave -1
All 4000 tests ran as expected.
Comment 8 Antoine Quint 2020-02-24 03:59:14 PST
Created attachment 391523 [details]
Patch
Comment 9 Alexey Proskuryakov 2020-02-24 06:56:44 PST
Comment on attachment 391523 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=391523&action=review

> LayoutTests/ChangeLog:9
> +        Since this test should be using the legacy animation engine, ensure that it does.

The patch doesn’t remove the flaky expectation.
Comment 10 Antoine Quint 2020-02-24 07:02:29 PST
Created attachment 391533 [details]
Patch for landing
Comment 11 WebKit Commit Bot 2020-02-24 07:32:26 PST
Comment on attachment 391533 [details]
Patch for landing

Clearing flags on attachment: 391533

Committed r257204: <https://trac.webkit.org/changeset/257204>
Comment 12 WebKit Commit Bot 2020-02-24 07:32:28 PST
All reviewed patches have been landed.  Closing bug.