Bug 207337 - http/wpt/css/css-animations/start-animation-001.html is flaky failing
Summary: http/wpt/css/css-animations/start-animation-001.html is flaky failing
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Animations (show other bugs)
Version: WebKit Nightly Build
Hardware: Macintosh Unspecified
: P2 Normal
Assignee: Antoine Quint
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2020-02-06 09:34 PST by Jason Lawrence
Modified: 2020-03-23 09:48 PDT (History)
10 users (show)

See Also:


Attachments
Update Test Expectations (1.56 KB, patch)
2020-02-06 09:39 PST, Jason Lawrence
no flags Details | Formatted Diff | Diff
Update Test Expectations (1.57 KB, patch)
2020-02-06 09:41 PST, Jason Lawrence
no flags Details | Formatted Diff | Diff
Patch (4.71 KB, patch)
2020-03-17 09:19 PDT, Antoine Quint
dino: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Lawrence 2020-02-06 09:34:35 PST
http/wpt/css/css-animations/start-animation-001.html

Description:
This test is flaky failing on Mac wk1. It possibly regressed when r255131 was rolled out with r255150.

History:
https://results.webkit.org/?suite=layout-tests&test=http%2Fwpt%2Fcss%2Fcss-animations%2Fstart-animation-001.html&platform=mac&flavor=wk1&limit=50000

Diff:
https://build.webkit.org/results/Apple-Catalina-Debug-WK1-Tests/r255910%20(2297)/http/wpt/css/css-animations/start-animation-001-diff.png
Comment 1 Jason Lawrence 2020-02-06 09:39:12 PST
Created attachment 389967 [details]
Update Test Expectations
Comment 2 Jason Lawrence 2020-02-06 09:41:47 PST
Created attachment 389968 [details]
Update Test Expectations
Comment 3 Radar WebKit Bug Importer 2020-02-06 09:43:02 PST
<rdar://problem/59226371>
Comment 4 Jason Lawrence 2020-02-06 15:00:50 PST
I am not able to reproduce this issue with iterations, test-list, debug or Guard Malloc.
Comment 5 Truitt Savell 2020-02-06 15:14:06 PST
Landed proper expectations in https://trac.webkit.org/changeset/255979/webkit
Comment 6 Alexey Proskuryakov 2020-02-08 13:16:49 PST
> This test is flaky failing on Mac wk1. It possibly regressed when r255131 was rolled out with r255150.

There were no failures on wk1 between r254153 and r255154, so I don't see evidence for this claim. Also, it fails on wk2 too, including in this range.
Comment 7 Jacob Uphoff 2020-02-13 08:27:21 PST
I can reproduce this by running the test in iterations x5000 ( failed 18 times )
Comment 8 Jacob Uphoff 2020-02-13 08:29:15 PST
Set proper expectations here: https://trac.webkit.org/changeset/256506/webkit
Comment 9 Antoine Quint 2020-03-17 09:19:13 PDT
Created attachment 393759 [details]
Patch
Comment 10 Antoine Quint 2020-03-17 12:39:58 PDT
Committed r258572: <https://trac.webkit.org/changeset/258572>
Comment 11 Aakash Jain 2020-03-20 05:33:40 PDT
(In reply to Antoine Quint from comment #10)
> Committed r258572: <https://trac.webkit.org/changeset/258572>
It seems like http/wpt/css/css-animations/start-animation-001.html is failing on Windows EWS since this change. Can you have a look?
e.g.: https://ews-build.webkit.org/results/Windows-EWS/r394076-12243-clean-tree/results.html
Comment 12 Antoine Quint 2020-03-23 09:46:13 PDT
(In reply to Aakash Jain from comment #11)
> (In reply to Antoine Quint from comment #10)
> > Committed r258572: <https://trac.webkit.org/changeset/258572>
> It seems like http/wpt/css/css-animations/start-animation-001.html is
> failing on Windows EWS since this change. Can you have a look?
> e.g.:
> https://ews-build.webkit.org/results/Windows-EWS/r394076-12243-clean-tree/
> results.html

While I've definitely seen that failure on Windows EWS bots, I cannot see it in our results database, https://results.webkit.org/?suite=layout-tests&test=http%2Fwpt%2Fcss%2Fcss-animations%2Fstart-animation-001.html.
Comment 13 Antoine Quint 2020-03-23 09:48:04 PDT
Tracking this failure in https://bugs.webkit.org/show_bug.cgi?id=209426.