Bug 206175 - Add support for MediaStream audio track rendering in GPUProcess
Summary: Add support for MediaStream audio track rendering in GPUProcess
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebRTC (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: youenn fablet
URL:
Keywords: InRadar
: 206236 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-01-13 08:12 PST by youenn fablet
Modified: 2020-01-15 05:01 PST (History)
12 users (show)

See Also:


Attachments
Patch (50.17 KB, patch)
2020-01-13 08:13 PST, youenn fablet
no flags Details | Formatted Diff | Diff
Patch (59.81 KB, patch)
2020-01-14 00:44 PST, youenn fablet
no flags Details | Formatted Diff | Diff
Patch (59.81 KB, patch)
2020-01-14 00:49 PST, youenn fablet
no flags Details | Formatted Diff | Diff
Fixing non MediaStream builds (59.55 KB, patch)
2020-01-15 01:08 PST, youenn fablet
no flags Details | Formatted Diff | Diff
Fixing non MediaStream builds (59.55 KB, patch)
2020-01-15 02:13 PST, youenn fablet
no flags Details | Formatted Diff | Diff
Patch for landing (54.47 KB, patch)
2020-01-15 03:55 PST, youenn fablet
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description youenn fablet 2020-01-13 08:12:18 PST
Add support for MediaStream audio track rendering in GPUProcess
Comment 1 youenn fablet 2020-01-13 08:13:20 PST
Created attachment 387530 [details]
Patch
Comment 2 youenn fablet 2020-01-14 00:44:48 PST
Created attachment 387628 [details]
Patch
Comment 3 youenn fablet 2020-01-14 00:49:20 PST
Created attachment 387629 [details]
Patch
Comment 4 WebKit Commit Bot 2020-01-14 06:37:56 PST
Comment on attachment 387629 [details]
Patch

Clearing flags on attachment: 387629

Committed r254505: <https://trac.webkit.org/changeset/254505>
Comment 5 WebKit Commit Bot 2020-01-14 06:37:57 PST
All reviewed patches have been landed.  Closing bug.
Comment 6 Radar WebKit Bug Importer 2020-01-14 06:38:13 PST
<rdar://problem/58566481>
Comment 7 Eric Carlson 2020-01-14 07:50:52 PST
Comment on attachment 387629 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=387629&action=review

> Source/WebKit/GPUProcess/webrtc/RemoteAudioMediaStreamTrackRenderer.h:39
> +namespace IPC {
> +class Connection;
> +class DataReference;
> +class Decoder;
> +}

These probably aren't necessary since you include MessageReceiver.h above.
Comment 8 youenn fablet 2020-01-14 08:04:32 PST
(In reply to Eric Carlson from comment #7)
> Comment on attachment 387629 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=387629&action=review
> 
> > Source/WebKit/GPUProcess/webrtc/RemoteAudioMediaStreamTrackRenderer.h:39
> > +namespace IPC {
> > +class Connection;
> > +class DataReference;
> > +class Decoder;
> > +}
> 
> These probably aren't necessary since you include MessageReceiver.h above.

Filed https://bugs.webkit.org/show_bug.cgi?id=206236
Comment 9 Ryan Haddad 2020-01-14 09:48:56 PST
Reverted r254505 for reason:

Breaks watchOS/tvOS/Catalyst builds.

Committed r254516: <https://trac.webkit.org/changeset/254516>
Comment 10 youenn fablet 2020-01-15 00:28:40 PST
*** Bug 206236 has been marked as a duplicate of this bug. ***
Comment 11 youenn fablet 2020-01-15 01:08:52 PST
Created attachment 387760 [details]
Fixing non MediaStream builds
Comment 12 WebKit Commit Bot 2020-01-15 02:09:05 PST
Comment on attachment 387760 [details]
Fixing non MediaStream builds

Rejecting attachment 387760 [details] from commit-queue.

Failed to run "['/Volumes/Data/EWS/WebKit/Tools/Scripts/webkit-patch', '--status-host=webkit-queues.webkit.org', '--bot-id=webkit-cq-01', 'validate-changelog', '--check-oops', '--non-interactive', 387760, '--port=mac']" exit_code: 1 cwd: /Volumes/Data/EWS/WebKit

ChangeLog entry in LayoutTests/ChangeLog contains OOPS!.

Full output: https://webkit-queues.webkit.org/results/13304664
Comment 13 youenn fablet 2020-01-15 02:13:49 PST
Created attachment 387767 [details]
Fixing non MediaStream builds
Comment 14 WebKit Commit Bot 2020-01-15 03:12:21 PST
The commit-queue encountered the following flaky tests while processing attachment 387767 [details]:

media/track/track-cues-sorted-before-dispatch.html bug 206225 (authors: simon.pena@samsung.com and vcarbune@chromium.org)
The commit-queue is continuing to process your patch.
Comment 15 WebKit Commit Bot 2020-01-15 03:12:30 PST
The commit-queue encountered the following flaky tests while processing attachment 387767 [details]:

http/tests/security/contentSecurityPolicy/report-status-code-zero-when-using-https.html bug 197297 (author: dbates@webkit.org)
The commit-queue is continuing to process your patch.
Comment 16 WebKit Commit Bot 2020-01-15 03:30:57 PST
Comment on attachment 387767 [details]
Fixing non MediaStream builds

Clearing flags on attachment: 387767

Committed r254562: <https://trac.webkit.org/changeset/254562>
Comment 17 WebKit Commit Bot 2020-01-15 03:30:58 PST
All reviewed patches have been landed.  Closing bug.
Comment 18 youenn fablet 2020-01-15 03:55:05 PST
Reopening to attach new patch.
Comment 19 youenn fablet 2020-01-15 03:55:08 PST
Created attachment 387774 [details]
Patch for landing