Bug 204650 - [Web Animations] Enable WebAnimationsCSSIntegrationEnabled by default
Summary: [Web Animations] Enable WebAnimationsCSSIntegrationEnabled by default
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Animations (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Antoine Quint
URL:
Keywords: InRadar
: 184569 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-11-27 11:44 PST by Antoine Quint
Modified: 2019-12-09 01:36 PST (History)
2 users (show)

See Also:


Attachments
Patch (2.67 KB, patch)
2019-11-27 11:45 PST, Antoine Quint
no flags Details | Formatted Diff | Diff
Patch (19.72 KB, patch)
2019-11-30 04:23 PST, Antoine Quint
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Antoine Quint 2019-11-27 11:44:53 PST
[Web Animations] Set WebAnimationsCSSIntegrationEnabled to true by default
Comment 1 Antoine Quint 2019-11-27 11:45:35 PST
Created attachment 384422 [details]
Patch
Comment 2 Antoine Quint 2019-11-27 11:45:44 PST
<rdar://problem/45562752>
Comment 3 Dean Jackson 2019-11-28 00:54:03 PST
Comment on attachment 384422 [details]
Patch

I think you should change the layout tests to reflect the default.
Comment 4 Antoine Quint 2019-11-28 04:48:54 PST
(In reply to Dean Jackson from comment #3)
> Comment on attachment 384422 [details]
> Patch
> 
> I think you should change the layout tests to reflect the default.

How do you mean? Layout tests have been running with that flag on for a long time already.
Comment 5 Antoine Quint 2019-11-29 10:15:14 PST
Committed r252945: <https://trac.webkit.org/changeset/252945>
Comment 6 Antoine Quint 2019-11-30 04:23:02 PST
Reopening to attach new patch.
Comment 7 Antoine Quint 2019-11-30 04:23:04 PST
Created attachment 384539 [details]
Patch
Comment 8 Antoine Quint 2019-11-30 04:24:47 PST
Comment on attachment 384539 [details]
Patch

Filed a new patch in error.
Comment 9 Antoine Quint 2019-12-09 01:36:31 PST
*** Bug 184569 has been marked as a duplicate of this bug. ***