Bug 204643 - [GTK] [2.27.3] GCMemoryOperations.h: Unknown architecture
Summary: [GTK] [2.27.3] GCMemoryOperations.h: Unknown architecture
Status: RESOLVED DUPLICATE of bug 204701
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-27 05:39 PST by Alberto Garcia
Modified: 2019-12-01 10:18 PST (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alberto Garcia 2019-11-27 05:39:26 PST
The latest development release of WebKitGTK fails to build in several
non-major architectures (mips64el, ppc64el, s390x, ...):

../Source/JavaScriptCore/heap/GCMemoryOperations.h:125:2: error: #error "Unknown architecture."
  125 | #error "Unknown architecture."

A quick look suggests that functions like gcSafeMemcpy() and possibly
others have fast implementations in x86_64 and arm64 but fall back to
a slower memcpy implementation in other cases.

The detection of when to use the slow path seems to be incorrect,
hence the error.
Comment 1 Yusuke Suzuki 2019-11-29 05:47:23 PST
We should add ENABLE_CONCURRENT_GC in Platform.h, and enable it only for X64 / ARM64.
And we should also ensure USE_CONCURRENT_JS is enabled in x64 / ARM64. Then, we should use regular memset/memcpy for non concurrent environment.
Comment 2 Alberto Garcia 2019-12-01 10:18:49 PST

*** This bug has been marked as a duplicate of bug 204701 ***