The master bug for implementing the Motion Path / Offset spec. https://drafts.fxtf.org/motion-1/
Goal is to get WebCore in parity with Blink's and Gecko's implementation initially. That means support for:
* offset-path (only none | path())
* offset shorthand
The implementation happens behind the runtime flag cssOffset
(In reply to Dirk Schulze from comment #1)
> The implementation happens behind the runtime flag cssOffset
Let's align the flag with the spec shortname.
(In reply to Simon Fraser (smfr) from comment #2)
> (In reply to Dirk Schulze from comment #1)
> > The implementation happens behind the runtime flag cssOffset
> Let's align the flag with the spec shortname.
I wonder if the CSS WG should rather rename the spec with its short name from motion to offset just like it renamed the properties. IMO it was an oversight and should be corrected to avoid confusions in the future.
However, I don’t mind to rename it here but would still ask the WG to rename.
To consider: All CSS properties (like logical units) are prefixed with css it seems.
"offset" sounds way too generic.
Changed the runtime flag name to "motion" with the first patch in https://bugs.webkit.org/show_bug.cgi?id=203848 as it is the shorthand of the spec.
*** Bug 139127 has been marked as a duplicate of this bug. ***