Bug 203403 - iPad video is upside down in 'reverse portrait' mode
Summary: iPad video is upside down in 'reverse portrait' mode
Status: RESOLVED DUPLICATE of bug 211373
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebRTC (show other bugs)
Version: Safari 13
Hardware: iPhone / iPad iOS 13
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-10-25 02:22 PDT by milen
Modified: 2020-05-26 11:08 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description milen 2019-10-25 02:22:56 PDT
Open Safari and go to: https://webrtc.github.io/samples/src/content/getusermedia/gum/
Click 'Open Camera' and try to rotate the device:

1) Portrait mode (home button down), the video looks good.
2) Landscape left mode (home button left), the video looks good.
3) Landscape right mode (home button right), the video looks good.
4) Reverse Portrait mode (home button up), the video looks upside down.

Tested on:
- iPad Mini 2, iOS 12.4.2
- iPad Pro, iOS 13.1.3

Safari on iPhone does not support the "Reverse Portrait mode". So it is obvious that the device is not correctly oriented.

On iPad Safari supports "Reverse Portrait mode". It rotates the UI but the video orientation is wrong.
Comment 1 Radar WebKit Bug Importer 2019-10-26 16:29:01 PDT
<rdar://problem/56649218>
Comment 2 Eric Carlson 2020-05-26 11:08:56 PDT
This was fixed by r261080.

*** This bug has been marked as a duplicate of bug 211373 ***