Bug 201702 - [JSC] SamplingProfiler should recognize RegExp execution
Summary: [JSC] SamplingProfiler should recognize RegExp execution
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Yusuke Suzuki
URL:
Keywords: InRadar
: 190336 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-09-11 15:41 PDT by Yusuke Suzuki
Modified: 2021-07-19 10:29 PDT (History)
12 users (show)

See Also:


Attachments
Patch (58.46 KB, patch)
2019-09-13 03:45 PDT, Yusuke Suzuki
no flags Details | Formatted Diff | Diff
Patch (49.01 KB, patch)
2021-07-15 18:51 PDT, Yusuke Suzuki
sbarati: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yusuke Suzuki 2019-09-11 15:41:37 PDT
Simply to investigate what RegExp is taking long time in several JetStream2 benchmarks.
Comment 1 Radar WebKit Bug Importer 2019-09-11 15:42:14 PDT
<rdar://problem/55279830>
Comment 2 Yusuke Suzuki 2019-09-13 02:43:57 PDT
After looking into the current SamplingProfiler and RegExp code, I think maybe, we should take a very simple way that is previously done in the previous patch because,

1. Yarr RegExp JIT code is not following JS calling-convention right now. And if we want to do that, we need to execute Yarr RegExp through LLInt vmEntry, it is not desirable.
2. RegExp JIT code must be a leaf of execution in terms of SamplingProfiler. So, just recording in VM is enough.
Comment 3 Yusuke Suzuki 2019-09-13 03:45:55 PDT
Created attachment 378721 [details]
Patch
Comment 4 Yusuke Suzuki 2021-07-15 18:51:27 PDT
Created attachment 433646 [details]
Patch
Comment 5 Saam Barati 2021-07-15 20:01:41 PDT
Comment on attachment 433646 [details]
Patch

Nice. r=me
Comment 6 Yusuke Suzuki 2021-07-15 21:10:59 PDT
Committed r279976 (239719@main): <https://commits.webkit.org/239719@main>
Comment 7 Yusuke Suzuki 2021-07-16 18:20:42 PDT
*** Bug 190336 has been marked as a duplicate of this bug. ***
Comment 8 Joseph Pecoraro 2021-07-19 10:29:13 PDT
Whoa! Awesome