Bug 200539 - [FTW] Get WebKit, WebKit2, and MiniBrowser building and executing
Summary: [FTW] Get WebKit, WebKit2, and MiniBrowser building and executing
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Misc. (show other bugs)
Version: Safari 10
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Brent Fulgham
URL:
Keywords: InRadar
Depends on:
Blocks: 161817
  Show dependency treegraph
 
Reported: 2019-08-08 09:06 PDT by Brent Fulgham
Modified: 2019-08-08 15:04 PDT (History)
7 users (show)

See Also:


Attachments
Patch (155.76 KB, patch)
2019-08-08 11:06 PDT, Brent Fulgham
no flags Details | Formatted Diff | Diff
Patch (147.58 KB, patch)
2019-08-08 11:33 PDT, Brent Fulgham
no flags Details | Formatted Diff | Diff
Patch for landing (147.10 KB, patch)
2019-08-08 13:16 PDT, Brent Fulgham
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Brent Fulgham 2019-08-08 09:06:55 PDT
This patch gets the remaining pieces of WebKit needed to run MiniBrowser working.
Comment 1 Radar WebKit Bug Importer 2019-08-08 09:20:25 PDT
<rdar://problem/54082550>
Comment 2 Brent Fulgham 2019-08-08 11:06:39 PDT
Created attachment 375823 [details]
Patch
Comment 3 Build Bot 2019-08-08 11:09:58 PDT
Attachment 375823 [details] did not pass style-queue:


ERROR: Source/WebKit/PlatformFTW.cmake:177:  Alphabetical sorting problem. "D2d1.lib" should be before "PRIVATE".  [list/order] [5]
Total errors found: 1 in 73 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 4 Brent Fulgham 2019-08-08 11:33:09 PDT
Created attachment 375826 [details]
Patch
Comment 5 Build Bot 2019-08-08 11:36:48 PDT
Attachment 375826 [details] did not pass style-queue:


ERROR: Source/WebKit/PlatformFTW.cmake:177:  Alphabetical sorting problem. "D2d1.lib" should be before "PRIVATE".  [list/order] [5]
Total errors found: 1 in 68 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 6 Brent Fulgham 2019-08-08 12:59:09 PDT
Windows is generating a weird error, that Google searching indicates is caused by a machine configuration issue:

c:\program files (x86)\windows kits\10\include\10.0.17134.0\cppwinrt\winrt\base.h(10253): error C2039: 'GetSystemTimePreciseAsFileTime': is not a member of '`global namespace'' [C:\cygwin\home\buildbot\WebKit\WebKitBuild\Release\Source\WebKitLegacy\WebKitLegacy.vcxproj]
c:\program files (x86)\windows kits\10\include\10.0.17134.0\cppwinrt\winrt\base.h(10253): error C3861: 'GetSystemTimePreciseAsFileTime': identifier not found [C:\cygwin\home\buildbot\WebKit\WebKitBuild\Release\Source\WebKitLegacy\WebKitLegacy.vcxproj]

We do not use or reference 'GetSystemTimePreciseAsFileTime' anywhere.
Comment 7 Brent Fulgham 2019-08-08 13:09:09 PDT
Comment on attachment 375826 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=375826&action=review

> Source/WebKitLegacy/win/WebKitPrefix.h:34
> +#include <winrt/Windows.Foundation.Collections.h>

Oh whoops! This is the build failure.
Comment 8 Brent Fulgham 2019-08-08 13:16:55 PDT
Created attachment 375834 [details]
Patch for landing
Comment 9 Build Bot 2019-08-08 14:24:45 PDT
Attachment 375834 [details] did not pass style-queue:


ERROR: Source/WebKit/PlatformFTW.cmake:177:  Alphabetical sorting problem. "D2d1.lib" should be before "PRIVATE".  [list/order] [5]
Total errors found: 1 in 67 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 10 WebKit Commit Bot 2019-08-08 15:04:06 PDT
Comment on attachment 375834 [details]
Patch for landing

Clearing flags on attachment: 375834

Committed r248444: <https://trac.webkit.org/changeset/248444>
Comment 11 WebKit Commit Bot 2019-08-08 15:04:07 PDT
All reviewed patches have been landed.  Closing bug.