Bug 199543 - [Pointer Events] Use a gesture recognizer to prevent pinch-to-zoom behavior
Summary: [Pointer Events] Use a gesture recognizer to prevent pinch-to-zoom behavior
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: UI Events (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Antoine Quint
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-07-06 07:36 PDT by Antoine Quint
Modified: 2019-07-08 04:23 PDT (History)
7 users (show)

See Also:


Attachments
Patch (22.36 KB, patch)
2019-07-06 07:45 PDT, Antoine Quint
no flags Details | Formatted Diff | Diff
Patch (22.38 KB, patch)
2019-07-06 11:59 PDT, Antoine Quint
no flags Details | Formatted Diff | Diff
Patch (22.23 KB, patch)
2019-07-06 14:37 PDT, Antoine Quint
graouts: review?
ews: commit-queue-
Details | Formatted Diff | Diff
Archive of layout-test-results from ews122 for ios-simulator-wk2 (1.19 MB, application/zip)
2019-07-06 15:58 PDT, Build Bot
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Antoine Quint 2019-07-06 07:36:44 PDT
[Pointer Events] Use a gesture recognizer to prevent pinch-to-zoom behavior
Comment 1 Antoine Quint 2019-07-06 07:45:07 PDT
Created attachment 373566 [details]
Patch
Comment 2 Antoine Quint 2019-07-06 11:59:59 PDT
Created attachment 373568 [details]
Patch
Comment 3 Dean Jackson 2019-07-06 13:47:16 PDT
Comment on attachment 373568 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=373568&action=review

> Source/WebKit/UIProcess/ios/WKContentViewInteraction.mm:146
> +#import "ScrollingTreeScrollingNodeDelegateIOS.h"

Why did you need to add this?
Comment 4 Antoine Quint 2019-07-06 14:35:30 PDT
(In reply to Dean Jackson from comment #3)
> Comment on attachment 373568 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=373568&action=review
> 
> > Source/WebKit/UIProcess/ios/WKContentViewInteraction.mm:146
> > +#import "ScrollingTreeScrollingNodeDelegateIOS.h"
> 
> Why did you need to add this?

I didn't, this was for a later patch and I forgot to remove it.
Comment 5 Antoine Quint 2019-07-06 14:37:52 PDT
Created attachment 373582 [details]
Patch
Comment 6 Build Bot 2019-07-06 15:58:38 PDT
Comment on attachment 373582 [details]
Patch

Attachment 373582 [details] did not pass ios-sim-ews (ios-simulator-wk2):
Output: https://webkit-queues.webkit.org/results/12677986

Number of test failures exceeded the failure limit.
Comment 7 Build Bot 2019-07-06 15:58:40 PDT
Created attachment 373586 [details]
Archive of layout-test-results from ews122 for ios-simulator-wk2

The attached test failures were seen while running run-webkit-tests on the ios-sim-ews.
Bot: ews122  Port: ios-simulator-wk2  Platform: Mac OS X 10.14.5
Comment 8 Antoine Quint 2019-07-07 01:13:04 PDT
Committed r247197: <https://trac.webkit.org/changeset/247197>
Comment 9 Radar WebKit Bug Importer 2019-07-07 01:14:23 PDT
<rdar://problem/52740554>
Comment 10 Antoine Quint 2019-07-07 08:14:34 PDT
Working on addressing the new timeouts on iOS Simulator, should have a fix up in the next few hours.
Comment 11 Antoine Quint 2019-07-07 08:45:01 PDT
(In reply to Antoine Quint from comment #10)
> Working on addressing the new timeouts on iOS Simulator, should have a fix
> up in the next few hours.

I think I know what the problem is, we should really have ENABLE_POINTER_EVENTS and HAVE_UI_WEB_TOUCH_EVENTS_GESTURE_RECOGNIZER_WITH_ACTIVE_TOUCHES_BY_ID be one and a single thing on iOS since we can't have pointercancel events or the touch-action CSS property implemented without that new API. Running tests locally to see if that indeed fixes everything, but this will take a few hours since mucking with Platform.h causes a complete rebuild.
Comment 12 Antoine Quint 2019-07-07 12:16:16 PDT
I have a patch up at https://bugs.webkit.org/show_bug.cgi?id=199562 to enable PE on iOS 13 and up only for iOS.
Comment 13 Antoine Quint 2019-07-08 04:23:10 PDT
Should be all clear as of r247205.