Bug 19927 - WebKit.app crashed after closing window
Summary: WebKit.app crashed after closing window
Status: RESOLVED DUPLICATE of bug 19926
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Cameron Zwarich (cpst)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-07 08:23 PDT by Morten Norby Larsen
Modified: 2008-07-07 17:04 PDT (History)
1 user (show)

See Also:


Attachments
Crash report (34.78 KB, text/plain)
2008-07-07 08:24 PDT, Morten Norby Larsen
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Morten Norby Larsen 2008-07-07 08:23:20 PDT
After visiting some newspaper web pages (full of all sorts of Flash-based advertsing) WebKit.app crashed a few seconds later.
Comment 1 Morten Norby Larsen 2008-07-07 08:24:17 PDT
Created attachment 22133 [details]
Crash report
Comment 2 Cameron Zwarich (cpst) 2008-07-07 10:50:47 PDT
I have seen this stack trace before, so I guess I will mark the bug as confirmed. Which version of the Flash player are you using? Do you have any clue which sites you were viewing?
Comment 3 Morten Norby Larsen 2008-07-07 11:21:29 PDT
Good point about the Flash version - it is a beta of Flash 10: 10.0.0.525 (from the bundle Info.plist)

Here are the sites I believe that I have visited during the session:

http://politiken.dk (several pages)
http://berlingske.dk (several pages)
http://guardian.co.uk - specifically:

http://blogs.guardian.co.uk/digitalcontent/2008/07/interview_blake_chandlee_uk_co.html
http://www.guardian.co.uk/technology/audio/2008/jul/07/facebook.digitaladvertising

I am certain, though, that I have seen crashes with Flash_EnforceLocalSecurity in the stack trace also with earlier (non-beta) versions of Flash. It used to happen all the time, but I don't know if it went away thanks to a bug fix or because I deleted some Flash preference file I found.
Comment 4 Cameron Zwarich (cpst) 2008-07-07 17:04:39 PDT
(In reply to comment #3)
> Good point about the Flash version - it is a beta of Flash 10: 10.0.0.525 (from
> the bundle Info.plist)

I was wondering if this was caused by a Flash issue, as the other person mentioned he had just upgraded to Flash 10, but it seems that the new beta of Flash came out around the same time that we made a change in WebKit. ;-)

> I am certain, though, that I have seen crashes with Flash_EnforceLocalSecurity
> in the stack trace also with earlier (non-beta) versions of Flash. It used to
> happen all the time, but I don't know if it went away thanks to a bug fix or
> because I deleted some Flash preference file I found.

If get a crash with a stack trace that has any WebKit symbols above a Flash_EnforceLocalSecurity, please post it as a WebKit bug.

This bug seems to be a duplicate of bug 19926, which thankfully has a reproducible test case.

*** This bug has been marked as a duplicate of 19926 ***