Bug 197847 - [GStreamer] Sound screeching when playing certain videos
Summary: [GStreamer] Sound screeching when playing certain videos
Status: RESOLVED MOVED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Media (show other bugs)
Version: Other
Hardware: Other Linux
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-13 11:24 PDT by azeikui6ziwjypjgu5w2tixgcxdaapxx
Modified: 2019-06-24 10:56 PDT (History)
4 users (show)

See Also:


Attachments
Debug log (316.56 KB, text/plain)
2019-05-16 11:24 PDT, Michael Catanzaro
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description azeikui6ziwjypjgu5w2tixgcxdaapxx 2019-05-13 11:24:35 PDT
Videos like : https://www.youtube.com/watch?v=bzOxzJNdpH0 and https://share.tube/videos/watch/afa7808a-fbaa-4707-8328-022602a72f3d and seemingly all of them just screech very loud noises every so often, it's not my audio setup since Firefox and Chromium (and other various audio applications) work just fine.

Epiphany version : 3.33.1-2b3776d2
Webkit version : WebKitGTK 2.24.1
OS : Fedora 30 but installed through Flatpak
Comment 1 Michael Catanzaro 2019-05-13 16:31:20 PDT
I can reproduce on https://share.tube/videos/watch/afa7808a-fbaa-4707-8328-022602a72f3d, but not on https://www.youtube.com/watch?v=bzOxzJNdpH0.

I started noticing this a few days ago on several other YouTube videos (though strangely, not the one you linked to). Very annoying. The commonality seems to be that all affected videos (including the one you linked to) use MP4, not WebM. I'm surprised I don't notice the issue during the first minute of that video, however.

(I'm also surprised multiple people watched the video, and even have an argument in the comments....)
Comment 2 Michael Catanzaro 2019-05-13 16:34:25 PDT
Note this YouTube video hangs the entire webpage when opened in system Epiphany (with no gstreamer-libav): bug #197861.
Comment 3 Philippe Normand 2019-05-16 03:53:22 PDT
Looks like this is a bug in the fdkaac decoder...

0:00:05.661134274    56 0x5644ba0a6050 WARN            audiodecoder gstaudiodecoder.c:3021:_gst_audio_decoder_error:<fdkaacdec0> error: decoding error: 16388
0:00:05.661322541    56 0x5644ba0a6050 WARN            audiodecoder gstaudiodecoder.c:3021:_gst_audio_decoder_error:<fdkaacdec0> error: decoding error: 16388
0:00:05.661530302    56 0x5644ba0a6050 WARN            audiodecoder gstaudiodecoder.c:3021:_gst_audio_decoder_error:<fdkaacdec0> error: decoding error: 16388
0:00:05.661784649    56 0x5644ba0a6050 WARN            audiodecoder gstaudiodecoder.c:3021:_gst_audio_decoder_error:<fdkaacdec0> error: decoding error: 16388
Comment 4 Philippe Normand 2019-05-16 04:02:06 PDT
This is a GNOME Runtime bug, you should upgrade to GStreamer 1.16... I can't reproduce the issue with the fdkaac decoder shipped in that version, while the runtime uses an old version (1.14.4).
Comment 5 Michael Catanzaro 2019-05-16 07:22:49 PDT
Progress: https://gitlab.com/freedesktop-sdk/freedesktop-sdk/issues/756
Comment 6 Michael Catanzaro 2019-05-16 10:16:48 PDT
Update to 1.16 will be for master only, update for stable is rejected.

Fix will be backported to 1.14 instead: https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/merge_requests/343

Thanks for debugging, Phil!
Comment 7 Michael Catanzaro 2019-05-16 10:26:27 PDT
(In reply to Michael Catanzaro from comment #6)
> Fix will be backported to 1.14 instead:
> https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/merge_requests/343

It's the wrong fix. All of those commits are for the encoder, not the decoder. GStreamer devs are confused, don't know what to backport.
Comment 8 Michael Catanzaro 2019-05-16 11:14:52 PDT
When playing the Ubuntu video manually with gst-play-1.0, we get:

ERROR debug information: ../../../ext/fdkaac/gstfdkaacdec.c(220): gst_fdkaacdec_handle_frame (): /GstPlayBin:playbin/GstURIDecodeBin:uridecodebin0/GstDecodeBin:decodebin0/GstFdkAacDec:fdkaacdec0:
decoding error: 16394
Reached end of play list.

which pretty strongly suggests this is not WebKit's fault.
Comment 9 Michael Catanzaro 2019-05-16 11:16:34 PDT
That is inside the runtime, btw. On my host system it fails due to missing MP4 support.

fdk-aac inside the runtime is https://gitlab.com/freedesktop-sdk/freedesktop-sdk/blob/18.08/elements/desktop/libfdk-aac.bst, a stripped version hosted by Fedora. That's not going to change, but of course we can report bugs or request updates, etc.
Comment 10 Michael Catanzaro 2019-05-16 11:18:02 PDT
(Reopening because we need to figure out where to move this to, and evidence suggests it may not be fixed in 1.16.)
Comment 11 Michael Catanzaro 2019-05-16 11:24:45 PDT
Created attachment 370050 [details]
Debug log

Debug log requested by Tim-Philipp
Comment 12 Michael Catanzaro 2019-05-16 11:31:05 PDT
(In reply to Michael Catanzaro from comment #10)
> (Reopening because we need to figure out where to move this to, and evidence
> suggests it may not be fixed in 1.16.)

It's definitely a problem with the fdk-aac version.
Comment 13 Michael Catanzaro 2019-05-16 12:06:01 PDT
Moved to https://bugzilla.redhat.com/show_bug.cgi?id=1711040
Comment 14 Michael Catanzaro 2019-05-22 10:47:01 PDT
freedesktop-sdk issue: https://gitlab.com/freedesktop-sdk/freedesktop-sdk/issues/781
Comment 15 Michael Catanzaro 2019-06-24 10:56:50 PDT
*** Bug 196293 has been marked as a duplicate of this bug. ***