Bug 197789 - Make database shm file safe for mmap
Summary: Make database shm file safe for mmap
Status: RESOLVED DUPLICATE of bug 197760
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Sihui Liu
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-05-10 11:21 PDT by Sihui Liu
Modified: 2019-05-10 11:52 PDT (History)
2 users (show)

See Also:


Attachments
Patch (1.54 KB, patch)
2019-05-10 11:27 PDT, Sihui Liu
sihui_liu: review?
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sihui Liu 2019-05-10 11:21:13 PDT
Remove the release assertion we used to prove shm file can be NSFileProtectionComplete.
Comment 1 Sihui Liu 2019-05-10 11:21:42 PDT
<rdar://problem/50628434>
Comment 2 Sihui Liu 2019-05-10 11:27:19 PDT
Created attachment 369573 [details]
Patch
Comment 3 Sihui Liu 2019-05-10 11:52:32 PDT

*** This bug has been marked as a duplicate of bug 197760 ***