Bug 196778 - Web Inspector: Timelines: can't reliably stop/start a recording
Summary: Web Inspector: Timelines: can't reliably stop/start a recording
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: WebKit Nightly Build
Hardware: All All
: P2 Normal
Assignee: Devin Rousso
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-04-10 12:56 PDT by Devin Rousso
Modified: 2019-04-11 14:06 PDT (History)
12 users (show)

See Also:


Attachments
Patch (70.67 KB, patch)
2019-04-10 13:38 PDT, Devin Rousso
no flags Details | Formatted Diff | Diff
Patch (89.69 KB, patch)
2019-04-11 11:43 PDT, Devin Rousso
no flags Details | Formatted Diff | Diff
Patch (89.69 KB, patch)
2019-04-11 13:19 PDT, Devin Rousso
no flags Details | Formatted Diff | Diff
Patch (89.69 KB, patch)
2019-04-11 13:26 PDT, Devin Rousso
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Devin Rousso 2019-04-10 12:56:02 PDT
Sometimes you can't reliably stop/start a timeline recording by clicking the button or hitting the spacebar.

# STEPS TO REPRODUCE:
1. inspect <https://wkwebviewtest.surge.sh>
2. go to the Timelines tab
3. reload the page, which will trigger a timeline recording (make sure "Stop recording once page loads" is NOT checked)
4. when the recording stops after 2s, immediately click the record button to resume the recording
 => recording doesn't always resume.
Comment 1 Devin Rousso 2019-04-10 12:56:24 PDT
<rdar://problem/47606798>
Comment 2 Devin Rousso 2019-04-10 13:38:25 PDT
Created attachment 367156 [details]
Patch

Patch to see how bots like the new state system.
Comment 3 Build Bot 2019-04-10 13:40:44 PDT
This patch modifies the inspector protocol. Please ensure that any frontend changes appropriately use feature checks for new protocol features.
Comment 4 WebKit Commit Bot 2019-04-10 15:49:00 PDT
Comment on attachment 367156 [details]
Patch

Clearing flags on attachment: 367156

Committed r244158: <https://trac.webkit.org/changeset/244158>
Comment 5 WebKit Commit Bot 2019-04-10 15:49:01 PDT
All reviewed patches have been landed.  Closing bug.
Comment 6 Truitt Savell 2019-04-11 08:41:33 PDT
It looks like the changes in https://trac.webkit.org/changeset/244158/webkit

has caused 8 test failures: 
inspector/timeline/line-column.html
inspector/timeline/timeline-event-CancelAnimationFrame.html
inspector/timeline/timeline-event-FireAnimationFrame.html
inspector/timeline/timeline-event-RequestAnimationFrame.html
inspector/timeline/timeline-event-TimerFire.html
inspector/timeline/timeline-event-TimerInstall.html
inspector/timeline/timeline-event-TimerRemove.html
inspector/timeline/timeline-recording.html

These tests are effecting all of Mac. Can this be resolved quickly? 

Diff of inspector/timeline/line-column.html:
https://build.webkit.org/results/Apple%20High%20Sierra%20Release%20WK2%20(Tests)/r244167%20(10623)/inspector/timeline/line-column-diff.txt

History of inspector/timeline/line-column.html:
https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=inspector%2Ftimeline%2Fline-column.html
Comment 7 Truitt Savell 2019-04-11 10:45:10 PDT
Reverted r244158 for reason:

Casued 8 inspector/timeline/ test failures.

Committed r244191: <https://trac.webkit.org/changeset/244191>
Comment 8 Devin Rousso 2019-04-11 11:43:29 PDT
Created attachment 367230 [details]
Patch
Comment 9 WebKit Commit Bot 2019-04-11 13:18:37 PDT Comment hidden (obsolete)
Comment 10 Devin Rousso 2019-04-11 13:19:54 PDT
Created attachment 367235 [details]
Patch
Comment 11 WebKit Commit Bot 2019-04-11 13:22:21 PDT Comment hidden (obsolete)
Comment 12 Devin Rousso 2019-04-11 13:26:16 PDT
Created attachment 367236 [details]
Patch
Comment 13 WebKit Commit Bot 2019-04-11 14:06:53 PDT
Comment on attachment 367236 [details]
Patch

Clearing flags on attachment: 367236

Committed r244195: <https://trac.webkit.org/changeset/244195>
Comment 14 WebKit Commit Bot 2019-04-11 14:06:55 PDT
All reviewed patches have been landed.  Closing bug.