Bug 196743 - [AutoSizing] Avoid making text paragraphs scroll horizontally when there is a wide table
Summary: [AutoSizing] Avoid making text paragraphs scroll horizontally when there is a...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: zalan
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-04-09 13:10 PDT by zalan
Modified: 2019-04-12 10:24 PDT (History)
9 users (show)

See Also:


Attachments
Patch (21.31 KB, patch)
2019-04-09 15:06 PDT, zalan
thorton: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description zalan 2019-04-09 13:10:45 PDT
<rdar://problem/43897551>
Comment 1 zalan 2019-04-09 15:06:08 PDT
Created attachment 367072 [details]
Patch
Comment 2 zalan 2019-04-09 16:42:24 PDT
Committed r244098: <https://trac.webkit.org/changeset/244098>
Comment 3 Radar WebKit Bug Importer 2019-04-09 16:43:17 PDT
<rdar://problem/49756050>
Comment 4 Truitt Savell 2019-04-10 13:49:36 PDT
It looks like the changes in https://trac.webkit.org/changeset/244098/webkit

are most likely responsible for the test fast/dynamic/paused-event-dispatch.html becoming a timeout. 

History:
https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=fast%2Fdynamic%2Fpaused-event-dispatch.html

build:
https://build.webkit.org/builders/Apple%20Mojave%20Debug%20WK1%20(Tests)/builds/2992
Comment 5 zalan 2019-04-10 15:15:04 PDT
(In reply to Truitt Savell from comment #4)
> It looks like the changes in https://trac.webkit.org/changeset/244098/webkit
> 
> are most likely responsible for the test
> fast/dynamic/paused-event-dispatch.html becoming a timeout. 
> 
> History:
> https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.
> html#showAllRuns=true&tests=fast%2Fdynamic%2Fpaused-event-dispatch.html
> 
> build:
> https://build.webkit.org/builders/Apple%20Mojave%20Debug%20WK1%20(Tests)/
> builds/2992
That's quite surprising because this testcase does not exercise auto-sizing at all.
Comment 6 Truitt Savell 2019-04-11 17:05:08 PDT
We were able to reproduce this failure using command:

run-webkit-tests fast/dynamic/crash-subtree-layout-when-auto-size-enabled.html fast/dynamic/paused-event-dispatch.html  -1 --no-retry

running the test fast/dynamic/crash-subtree-layout-when-auto-size-enabled.html, added in 244098, in front of the timing out test causes the timeout.
Comment 7 zalan 2019-04-11 18:00:53 PDT
(In reply to Truitt Savell from comment #6)
> We were able to reproduce this failure using command:
> 
> run-webkit-tests
> fast/dynamic/crash-subtree-layout-when-auto-size-enabled.html
> fast/dynamic/paused-event-dispatch.html  -1 --no-retry
> 
> running the test
> fast/dynamic/crash-subtree-layout-when-auto-size-enabled.html, added in
> 244098, in front of the timing out test causes the timeout.
Ok. Thanks! I'll look into it.
Comment 8 zalan 2019-04-12 09:42:36 PDT
This patch actually revealed a bug in the test framework. We don't reset the auto-sizing mode for subsequent runs.
Comment 9 Truitt Savell 2019-04-12 10:19:11 PDT
*** Bug 196789 has been marked as a duplicate of this bug. ***
Comment 10 Truitt Savell 2019-04-12 10:24:27 PDT
Tracking the test failure and underlying framework bug in https://bugs.webkit.org/show_bug.cgi?id=196789