Bug 196300 - [ iOS Sim WK2 ] Layout Test fast/visual-viewport/ios/min-scale-greater-than-one.html is a flaky failure
Summary: [ iOS Sim WK2 ] Layout Test fast/visual-viewport/ios/min-scale-greater-than-o...
Status: RESOLVED DUPLICATE of bug 196236
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-03-27 09:28 PDT by Shawn Roberts
Modified: 2020-02-12 15:27 PST (History)
8 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shawn Roberts 2019-03-27 09:28:59 PDT
The following layout test is failing on iOS Simulator Release WK2

fast/visual-viewport/ios/min-scale-greater-than-one.html

Probable cause:

Test recently started showing up on the dashboard around r242531 as a flaky failure on iOS Sim Release. Is a very flaky failure on dashboard, when running test locally it fails 10 times in 60 iterations with 1 child process, unsure if it's because I'm running iterations, but I do get the same diff that is on the bots.

I tested with several revisions from when it was made until current, but there appears to be a lot of code changes so I do not get consistent results. 

Reproduced with: 

run-webkit-tests fast/visual-viewport/ios/min-scale-greater-than-one.html --iterations 500 --child-process 1 --ios-simulator --exit-after-n-failures=10 --no-retry

Flakiness Dashboard:

https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=fast%2Fvisual-viewport%2Fios%2Fmin-scale-greater-than-one.html

Diff:

--- /Volumes/Data/slave/ios-simulator-12-release-tests-wk2/build/layout-test-results/fast/visual-viewport/ios/min-scale-greater-than-one-expected.txt
+++ /Volumes/Data/slave/ios-simulator-12-release-tests-wk2/build/layout-test-results/fast/visual-viewport/ios/min-scale-greater-than-one-actual.txt
@@ -2,7 +2,6 @@
 Scrolling to bottom
 PASS window.scrollY is expectedTop
 PASS Math.round(boundingClientRect.top) is expectedTop
-Tap dispatched
 Target clicked
 PASS successfullyParsed is true
Comment 1 Shawn Roberts 2019-03-27 09:29:24 PDT
Start with Simon for help since they created the test.
Comment 2 Radar WebKit Bug Importer 2019-03-27 09:29:57 PDT
<rdar://problem/49339115>
Comment 3 Shawn Roberts 2019-03-27 09:38:18 PDT
marked flay in https://trac.webkit.org/changeset/243547/webkit
Comment 4 Simon Fraser (smfr) 2019-03-27 09:39:40 PDT
Dean, did fast tap break this?
Comment 5 Jon Lee 2019-03-28 09:53:07 PDT
Can we combine this with 196236?
Comment 6 Shawn Roberts 2019-03-28 10:05:30 PDT
(In reply to Jon Lee from comment #5)
> Can we combine this with 196236?

I was hesitant because the generally flakiness of the test is addressed here, while the consistency of the Debug failures were isolated to a different revision. 

I can if it makes it easier for tracking however?
Comment 7 Ryan Haddad 2019-05-03 11:46:26 PDT
I'm going to go ahead and dupe this since the diff is the same.

*** This bug has been marked as a duplicate of bug 196236 ***
Comment 8 Jason Lawrence 2020-02-12 15:27:47 PST
This issue is still occurring, see the diff below.

https://build.webkit.org/results/Apple%20iPadOS%2013%20Simulator%20Release%20WK2%20(Tests)/r256466%20(2139)/fast/visual-viewport/ios/min-scale-greater-than-one-diff.txt
@@ -2,7 +2,6 @@
 Scrolling to bottom
 PASS window.scrollY is expectedTop
 PASS Math.round(boundingClientRect.top) is expectedTop
-Tap dispatched
 Target clicked
 PASS successfullyParsed is true


I have marked this test as failing while this is investigated further.
https://trac.webkit.org/changeset/256486/webkit