Bug 195155 - Add a quirk for bostongloble.com and latimes.com
Summary: Add a quirk for bostongloble.com and latimes.com
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Sihui Liu
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-02-28 02:14 PST by Sihui Liu
Modified: 2019-03-01 11:55 PST (History)
8 users (show)

See Also:


Attachments
Patch (7.16 KB, patch)
2019-02-28 02:16 PST, Sihui Liu
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ews115 for mac-highsierra (2.25 MB, application/zip)
2019-02-28 17:59 PST, Build Bot
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sihui Liu 2019-02-28 02:14:48 PST
They are using window.openDatabase for detecting private mode, and this won't work without WebSQL support.
Comment 1 Sihui Liu 2019-02-28 02:16:36 PST
Created attachment 363214 [details]
Patch
Comment 2 Geoffrey Garen 2019-02-28 11:09:13 PST
Comment on attachment 363214 [details]
Patch

r=me
Comment 3 Build Bot 2019-02-28 17:58:59 PST
Comment on attachment 363214 [details]
Patch

Attachment 363214 [details] did not pass mac-debug-ews (mac):
Output: https://webkit-queues.webkit.org/results/11323833

New failing tests:
storage/indexeddb/modern/blocked-open-db-requests-private.html
Comment 4 Build Bot 2019-02-28 17:59:01 PST
Created attachment 363283 [details]
Archive of layout-test-results from ews115 for mac-highsierra

The attached test failures were seen while running run-webkit-tests on the mac-debug-ews.
Bot: ews115  Port: mac-highsierra  Platform: Mac OS X 10.13.6
Comment 5 Sihui Liu 2019-03-01 11:28:18 PST
The test failure are not caused by this patch: https://bugs.webkit.org/show_bug.cgi?id=195210.
Comment 6 Sihui Liu 2019-03-01 11:29:50 PST
<rdar://problem/48445011>
Comment 7 WebKit Commit Bot 2019-03-01 11:55:54 PST
Comment on attachment 363214 [details]
Patch

Clearing flags on attachment: 363214

Committed r242278: <https://trac.webkit.org/changeset/242278>
Comment 8 WebKit Commit Bot 2019-03-01 11:55:56 PST
All reviewed patches have been landed.  Closing bug.