Bug 195210 - REGRESSION: (r242189): Seven Layout Tests in storage/indexeddb/ are crashing after r242189
Summary: REGRESSION: (r242189): Seven Layout Tests in storage/indexeddb/ are crashing ...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-03-01 09:01 PST by Truitt Savell
Modified: 2019-03-04 08:58 PST (History)
6 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Truitt Savell 2019-03-01 09:01:03 PST
The following layout tests are crashing on Mac Debug WK1

storage/indexeddb/intversion-open-in-upgradeneeded-private.html 
storage/indexeddb/intversion-open-in-upgradeneeded.html 
storage/indexeddb/modern/abort-requests-cancelled-private.html 
storage/indexeddb/modern/abort-requests-cancelled.html 
storage/indexeddb/modern/blocked-open-db-requests-private.html 
storage/indexeddb/odd-strings-private.html

Probable cause:

These tests began crashing after the rollout of https://trac.webkit.org/changeset/242014/webkit in https://trac.webkit.org/changeset/242189/webkit. Possibly some change was made that was dependent on 242014 before it was rolled out. Currently these tests are slowing down WK1 EWS. These tests are reproducible locally by just running these tests on a checkout of r242189. 

This is related to https://bugs.webkit.org/show_bug.cgi?id=195141

Flakiness Dashboard:

https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=storage%2Findexeddb%2Fintversion-open-in-upgradeneeded-private.html%20storage%2Findexeddb%2Fintversion-open-in-upgradeneeded.html%20storage%2Findexeddb%2Fmodern%2Fabort-requests-cancelled-private.html%20storage%2Findexeddb%2Fmodern%2Fabort-requests-cancelled.html%20storage%2Findexeddb%2Fmodern%2Fblocked-open-db-requests-private.html%20storage%2Findexeddb%2Fodd-strings-private.html
Comment 1 Truitt Savell 2019-03-01 09:09:03 PST
Marked tests skip while investigating and to get EWS caught up: https://trac.webkit.org/changeset/242264/webkit
Comment 2 Truitt Savell 2019-03-01 12:56:33 PST
This additional test appears to be crashing often on EWS alone 
storage/indexeddb/modern/blocked-open-db-requests.html

https://webkit-queues.webkit.org/results/11334458

This is continuing to slow EWS
Comment 3 Truitt Savell 2019-03-01 13:00:50 PST
Skipped in: https://trac.webkit.org/changeset/242282/webkit
Comment 5 Radar WebKit Bug Importer 2019-03-01 14:28:44 PST
<rdar://problem/48523172>
Comment 6 Truitt Savell 2019-03-01 15:06:58 PST
It appears that after skipping some tests others begin to crash. I have not been able to narrow down which test is at fault for the crashes later in the test runner.
Comment 7 Truitt Savell 2019-03-01 16:17:25 PST
I talked with sihui and she found that https://trac.webkit.org/changeset/242075/webkit is calling a function from r242014 and is crashing due to the rollout. Looks like we will need to roll this change out too to resolve the crashing tests.
Comment 8 Xabier Rodríguez Calvar 2019-03-04 03:30:46 PST
(In reply to Truitt Savell from comment #7)
> I talked with sihui and she found that
> https://trac.webkit.org/changeset/242075/webkit is calling a function from
> r242014 and is crashing due to the rollout. Looks like we will need to roll
> this change out too to resolve the crashing tests.

No, you can't roll out my change. I didn't touch that function per-se. I just unveiled a hidden bug.
Comment 9 Xabier Rodríguez Calvar 2019-03-04 04:13:25 PST
Besides I don't know if this is still valid as it looks like there's r242308 landing that part of r242014
Comment 10 Xabier Rodríguez Calvar 2019-03-04 04:18:49 PST
And the link to the flakiness dashboard says they are green now, so I'd say we're cool here now.
Comment 11 Xabier Rodríguez Calvar 2019-03-04 04:19:23 PST
It was Darin, btw, who landed r242308.
Comment 12 Truitt Savell 2019-03-04 08:58:07 PST
Issue does appear to be resolved by r242308. I unskipped the tests in: https://trac.webkit.org/changeset/242358/webkit