Bug 194575 - generateUnlinkedCodeBlockForFunctions has a UAF
Summary: generateUnlinkedCodeBlockForFunctions has a UAF
Status: RESOLVED DUPLICATE of bug 194536
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Saam Barati
URL:
Keywords:
Depends on:
Blocks: 194576
  Show dependency treegraph
 
Reported: 2019-02-12 17:51 PST by Saam Barati
Modified: 2019-02-13 02:05 PST (History)
12 users (show)

See Also:


Attachments
patch (2.03 KB, patch)
2019-02-12 17:56 PST, Saam Barati
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Saam Barati 2019-02-12 17:51:20 PST
...
Comment 1 Saam Barati 2019-02-12 17:56:35 PST
Created attachment 361878 [details]
patch

Tadeu, is there an infrastructure in place where I can test this function?
Comment 2 Tadeu Zagallo 2019-02-13 01:31:44 PST
I had a patch in https://bugs.webkit.org/show_bug.cgi?id=194536 for this. Right now, we only test the cache by running the stress tests with the cache enable + a test for the JSScript caching in the api tests.
Comment 3 Saam Barati 2019-02-13 02:05:20 PST

*** This bug has been marked as a duplicate of bug 194536 ***