Bug 194411 - [Mac] WebInspectorUI.framework does not need to be soft-linked anymore
Summary: [Mac] WebInspectorUI.framework does not need to be soft-linked anymore
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: WebKit Nightly Build
Hardware: All All
: P2 Normal
Assignee: Brian Burg
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-02-07 13:30 PST by Brian Burg
Modified: 2019-02-15 11:02 PST (History)
13 users (show)

See Also:


Attachments
Patch (17.91 KB, patch)
2019-02-07 14:05 PST, Brian Burg
no flags Details | Formatted Diff | Diff
Patch (20.88 KB, patch)
2019-02-14 12:21 PST, Brian Burg
no flags Details | Formatted Diff | Diff
Patch (20.88 KB, patch)
2019-02-14 13:26 PST, Brian Burg
no flags Details | Formatted Diff | Diff
Patch (20.82 KB, patch)
2019-02-15 10:37 PST, Brian Burg
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Burg 2019-02-07 13:30:24 PST
This was re-added by https://bugs.webkit.org/show_bug.cgi?id=118544. It is no longer needed.
Comment 1 Brian Burg 2019-02-07 13:30:45 PST
<rdar://problem/47787614>
Comment 2 Brian Burg 2019-02-07 14:05:46 PST
Created attachment 361440 [details]
Patch
Comment 3 Joseph Pecoraro 2019-02-07 15:39:55 PST
Comment on attachment 361440 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=361440&action=review

> Source/WebKit/Configurations/WebKit.xcconfig:131
> +WK_WEBINSPECTORUI_LDFLAGS = $(WK_WEBINSPECTORUI_LDFLAGS_$(WK_PLATFORM_NAME));
> +WK_WEBINSPECTORUI_LDFLAGS_macosx = -framework WebInspectorUI;

I don't think we can hard link WebInspectorUI as it doesn't look like WebInspectorUI.framework is available in the Base System.
Comment 4 Joseph Pecoraro 2019-02-07 15:41:35 PST
Comment on attachment 361440 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=361440&action=review

>> Source/WebKit/Configurations/WebKit.xcconfig:131
>> +WK_WEBINSPECTORUI_LDFLAGS_macosx = -framework WebInspectorUI;
> 
> I don't think we can hard link WebInspectorUI as it doesn't look like WebInspectorUI.framework is available in the Base System.

Correction: is *not* available
Comment 5 Darin Adler 2019-02-09 12:44:06 PST
Comment on attachment 361440 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=361440&action=review

>>> Source/WebKit/Configurations/WebKit.xcconfig:131
>>> +WK_WEBINSPECTORUI_LDFLAGS_macosx = -framework WebInspectorUI;
>> 
>> I don't think we can hard link WebInspectorUI as it doesn't look like WebInspectorUI.framework is available in the Base System.
> 
> Correction: is *not* available

So we could consider switching from soft linking to weak linking.
Comment 6 Joseph Pecoraro 2019-02-11 11:03:51 PST
Good point, weak linking should work.
Comment 7 Brian Burg 2019-02-14 11:50:53 PST
Reopening to try -weak_framework based approach.
Comment 8 Brian Burg 2019-02-14 12:21:56 PST
Created attachment 362046 [details]
Patch
Comment 9 Joseph Pecoraro 2019-02-14 12:37:33 PST
Comment on attachment 362046 [details]
Patch

r=me
Comment 10 Brian Burg 2019-02-14 13:26:04 PST
Created attachment 362056 [details]
Patch
Comment 11 Joseph Pecoraro 2019-02-14 13:49:15 PST
Comment on attachment 362056 [details]
Patch

r=me still =)
Comment 12 Brian Burg 2019-02-14 14:32:27 PST
Committed r241564: <https://trac.webkit.org/changeset/241564>
Comment 13 Truitt Savell 2019-02-15 07:58:19 PST
After the changes in https://trac.webkit.org/changeset/241564/webkit

Mac WK2 has 50+ Timeouts and is exiting early. These are mostly in the http/ directory. 

Results:
https://build.webkit.org/results/Apple%20Mojave%20Release%20WK2%20(Tests)/r241565%20(2502)/results.html

Build:
https://build.webkit.org/builders/Apple%20Mojave%20Release%20WK2%20%28Tests%29/builds/2502

Confirmed this locally with:
run-webkit-tests --root testbuild-241564 http/ -f

Timeouts occur throughout the directory on 241564 but not on 241563
Comment 14 Truitt Savell 2019-02-15 08:11:11 PST
Reverted r241564 for reason:

Caused 50+ Timeouts on Mac WK2, mostly in the http/ directory

Committed r241586: <https://trac.webkit.org/changeset/241586>
Comment 15 Brian Burg 2019-02-15 10:20:07 PST
Comment on attachment 362056 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=362056&action=review

> Source/WebKit/UIProcess/mac/WebInspectorProxyMac.mm:743
> +    NSString *path = [bundle pathForResource:@"Main" ofType:@"html"];

When splitting up this line, I introduced a typo. Tests fail because it isn't loading Test.html. I must have run WKTR against a stale build, or something.
Comment 16 Brian Burg 2019-02-15 10:37:26 PST
Created attachment 362126 [details]
Patch
Comment 17 Brian Burg 2019-02-15 11:02:04 PST
Committed r241597: <https://trac.webkit.org/changeset/241597>