Bug 194274 - [WPE][GTK] Defer sandboxing APIs to 2.26
Summary: [WPE][GTK] Defer sandboxing APIs to 2.26
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: WebKit Nightly Build
Hardware: PC Linux
: P2 Normal
Assignee: Michael Catanzaro
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-02-04 20:47 PST by Michael Catanzaro
Modified: 2019-02-15 09:15 PST (History)
8 users (show)

See Also:


Attachments
Patch (1.98 KB, patch)
2019-02-04 20:48 PST, Michael Catanzaro
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Catanzaro 2019-02-04 20:47:53 PST
The web process sandbox has not been widely-tested yet, so we should defer the new APIs to 2.26.

This is the patch for trunk. I can provide another patch for 2.24 later if desired. Besides removing the APIs, we should also remove the bubblewrap dependency on that branch.
Comment 1 Michael Catanzaro 2019-02-04 20:48:53 PST
Created attachment 361154 [details]
Patch
Comment 2 Build Bot 2019-02-04 20:51:51 PST
Thanks for the patch. If this patch contains new public API please make sure it follows the guidelines for new WebKit2 GTK+ API. See http://trac.webkit.org/wiki/WebKitGTK/AddingNewWebKit2API
Comment 3 WebKit Commit Bot 2019-02-15 09:15:05 PST
Comment on attachment 361154 [details]
Patch

Clearing flags on attachment: 361154

Committed r241589: <https://trac.webkit.org/changeset/241589>
Comment 4 WebKit Commit Bot 2019-02-15 09:15:06 PST
All reviewed patches have been landed.  Closing bug.