Bug 193956 - REGRESSION (r240358): IndexedDB/large-binary-keys.html and IndexedDB/large-string-keys.html perf tests failing
Summary: REGRESSION (r240358): IndexedDB/large-binary-keys.html and IndexedDB/large-st...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Sihui Liu
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-01-28 22:06 PST by Ryan Haddad
Modified: 2019-01-31 17:12 PST (History)
10 users (show)

See Also:


Attachments
Patch (2.13 KB, patch)
2019-01-30 18:35 PST, Sihui Liu
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ews121 for ios-simulator-wk2 (2.46 MB, application/zip)
2019-01-30 20:46 PST, Build Bot
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Haddad 2019-01-28 22:06:06 PST
IndexedDB/large-binary-keys.html and IndexedDB/large-string-keys.html perf tests are failing, as seen here:
https://build.webkit.org/builders/Apple%20High%20Sierra%20Release%20WK2%20%28Perf%29/builds/135

Running IndexedDB/large-binary-keys.html (79 of 185)
timeout: IndexedDB/large-binary-keys.html
FAILED
Finished: 605.025108 s

Running IndexedDB/large-string-keys.html (82 of 185)
timeout: IndexedDB/large-string-keys.html
FAILED
Finished: 605.021979 s

This regressed between r240348 and r240361.
Comment 1 Ryan Haddad 2019-01-28 22:07:31 PST
This is probably related to:
"Clean up IndexedDB files between tests"
https://trac.webkit.org/changeset/240358/webkit
Comment 2 Radar WebKit Bug Importer 2019-01-28 22:07:49 PST
<rdar://problem/47623109>
Comment 3 Sihui Liu 2019-01-30 18:35:32 PST
Created attachment 360666 [details]
Patch
Comment 4 Build Bot 2019-01-30 20:46:55 PST
Comment on attachment 360666 [details]
Patch

Attachment 360666 [details] did not pass ios-sim-ews (ios-simulator-wk2):
Output: https://webkit-queues.webkit.org/results/10963066

New failing tests:
imported/w3c/web-platform-tests/webrtc/simplecall-no-ssrcs.https.html
Comment 5 Build Bot 2019-01-30 20:46:57 PST
Created attachment 360685 [details]
Archive of layout-test-results from ews121 for ios-simulator-wk2

The attached test failures were seen while running run-webkit-tests on the ios-sim-ews.
Bot: ews121  Port: ios-simulator-wk2  Platform: Mac OS X 10.13.6
Comment 6 Ryosuke Niwa 2019-01-30 23:37:31 PST
Comment on attachment 360666 [details]
Patch

There is no way this could have caused the iOS test failure because this patch simply fixes the failing performance tests.
Comment 7 WebKit Commit Bot 2019-01-31 00:06:22 PST
Comment on attachment 360666 [details]
Patch

Clearing flags on attachment: 360666

Committed r240767: <https://trac.webkit.org/changeset/240767>
Comment 8 WebKit Commit Bot 2019-01-31 00:06:24 PST
All reviewed patches have been landed.  Closing bug.
Comment 9 Ryosuke Niwa 2019-01-31 17:12:14 PST
The tests are passing now.