Bug 193669 - [build.webkit.org] Unit-test failure after r237113
Summary: [build.webkit.org] Unit-test failure after r237113
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Aakash Jain
URL:
Keywords: InRadar
: 191318 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-01-22 06:58 PST by Aakash Jain
Modified: 2019-01-23 09:56 PST (History)
9 users (show)

See Also:


Attachments
Unit-test fix (3.22 KB, patch)
2019-01-22 07:18 PST, Aakash Jain
mcatanzaro: review-
Details | Formatted Diff | Diff
Proposed patch (1.51 KB, patch)
2019-01-22 09:39 PST, Aakash Jain
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ews115 for mac-highsierra (2.10 MB, application/zip)
2019-01-22 11:08 PST, EWS Watchlist
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aakash Jain 2019-01-22 06:58:40 PST
2 unit-tests are failing. It seems to be since https://trac.webkit.org/changeset/237113/webkit

-bash-4.2$ ./steps_unittest.py
......................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................FF....................................................

======================================================================
FAIL: test_builder GTK Linux 64-bit Release Debian Stable (Build) (__main__.BuildStepsTest)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "./steps_unittest.py", line 591, in doTest
    self.assertListEqual(expected_build_steps[builder['name']], buildSteps)
AssertionError: Lists differ: ['configure build', 'svn', 'ki... != ['configure build', 'svn', 'ki...

First differing element 5:
compile-webkit
jhbuild

Second list contains 1 additional elements.
First extra element 6:
compile-webkit

  ['configure build',
   'svn',
   'kill old processes',
   'delete WebKitBuild directory',
   'delete stale build files',
+  'jhbuild',
   'compile-webkit']

======================================================================
FAIL: test_builder GTK Linux 64-bit Release Ubuntu LTS (Build) (__main__.BuildStepsTest)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "./steps_unittest.py", line 591, in doTest
    self.assertListEqual(expected_build_steps[builder['name']], buildSteps)
AssertionError: Lists differ: ['configure build', 'svn', 'ki... != ['configure build', 'svn', 'ki...

First differing element 5:
compile-webkit
jhbuild

Second list contains 1 additional elements.
First extra element 6:
compile-webkit

  ['configure build',
   'svn',
   'kill old processes',
   'delete WebKitBuild directory',
   'delete stale build files',
+  'jhbuild',
   'compile-webkit']

----------------------------------------------------------------------
Ran 764 tests in 0.395s

FAILED (failures=2)
Comment 1 Aakash Jain 2019-01-22 07:18:06 PST
Created attachment 359734 [details]
Unit-test fix
Comment 2 Michael Catanzaro 2019-01-22 08:50:01 PST
Comment on attachment 359734 [details]
Unit-test fix

Since this is not the expected result, could we please do the fix you proposed in bug #190581 instead:

"""
If this step is not expected, factories.py L42 should be changed to something like:

    if platform == "gtk" and "--no-experimental-features" not in additionalArguments:
"""
Comment 3 Aakash Jain 2019-01-22 09:39:45 PST
Created attachment 359742 [details]
Proposed patch

Updated factories.py L42 appropriately. Also took care of the case when 'additionalArguments' is None.

Unit-tests pass after this change.
Comment 4 EWS Watchlist 2019-01-22 11:08:35 PST Comment hidden (obsolete)
Comment 5 EWS Watchlist 2019-01-22 11:08:37 PST Comment hidden (obsolete)
Comment 6 Michael Catanzaro 2019-01-22 12:11:54 PST
Comment on attachment 359742 [details]
Proposed patch

View in context: https://bugs.webkit.org/attachment.cgi?id=359742&action=review

> Tools/BuildSlaveSupport/build.webkit.org-config/factories.py:42
> -        if platform == "gtk" and additionalArguments != ["--no-experimental-features"]:
> +        if platform == "gtk" and "--no-experimental-features" not in (additionalArguments or []):

Why do you need the "or []"?
Comment 7 Aakash Jain 2019-01-22 12:23:13 PST
> Why do you need the "or []"?

since additionalArguments can be None.
Comment 8 WebKit Commit Bot 2019-01-22 13:25:12 PST
Comment on attachment 359742 [details]
Proposed patch

Clearing flags on attachment: 359742

Committed r240291: <https://trac.webkit.org/changeset/240291>
Comment 9 WebKit Commit Bot 2019-01-22 13:25:14 PST
All reviewed patches have been landed.  Closing bug.
Comment 10 Radar WebKit Bug Importer 2019-01-22 13:26:30 PST
<rdar://problem/47457588>
Comment 11 Ryan Haddad 2019-01-23 09:56:47 PST
*** Bug 191318 has been marked as a duplicate of this bug. ***