Bug 192423 - Flaky Test: imported/w3c/web-platform-tests/WebCryptoAPI/generateKey/failures_AES-KW.https.any.worker.html
Summary: Flaky Test: imported/w3c/web-platform-tests/WebCryptoAPI/generateKey/failures...
Status: RESOLVED DUPLICATE of bug 192050
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: WebKit Commit Bot
URL:
Keywords:
Depends on:
Blocks: 50856
  Show dependency treegraph
 
Reported: 2018-12-05 12:47 PST by WebKit Commit Bot
Modified: 2018-12-06 09:05 PST (History)
2 users (show)

See Also:


Attachments
Archive of layout-test-results from webkit-cq-03 (2.47 MB, application/zip)
2018-12-05 12:47 PST, WebKit Commit Bot
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description WebKit Commit Bot 2018-12-05 12:47:47 PST
This is an automatically generated bug from the commit-queue.
imported/w3c/web-platform-tests/WebCryptoAPI/generateKey/failures_AES-KW.https.any.worker.html has been flaky on the commit-queue.

imported/w3c/web-platform-tests/WebCryptoAPI/generateKey/failures_AES-KW.https.any.worker.html was authored by .
https://trac.webkit.org/browser/trunk/LayoutTests/imported/w3c/web-platform-tests/WebCryptoAPI/generateKey/failures_AES-KW.https.any.worker.html

The commit-queue just saw imported/w3c/web-platform-tests/WebCryptoAPI/generateKey/failures_AES-KW.https.any.worker.html flake (DumpRenderTree crashed) while processing attachment 356638 [details] on bug 192421.
Bot: webkit-cq-03  Port: <class 'webkitpy.common.config.ports.MacPort'>  Platform: Mac OS X 10.12.6

The bots will update this with information from each new failure.

If you believe this bug to be fixed or invalid, feel free to close.  The bots will re-open if the flake re-occurs.

If you would like to track this test fix with another bug, please close this bug as a duplicate.  The bots will follow the duplicate chain when making future comments.
Comment 1 WebKit Commit Bot 2018-12-05 12:47:48 PST
Created attachment 356643 [details]
Archive of layout-test-results from webkit-cq-03
Comment 2 Ryan Haddad 2018-12-06 09:05:55 PST
Thread 48 Crashed:: WebCore: Worker
0   com.apple.JavaScriptCore      	0x00000001070236c5 JSC::speculationFromValue(JSC::JSValue) + 213 (SpeculatedType.cpp:477)
1   com.apple.JavaScriptCore      	0x0000000106ff4f66 JSC::CodeBlock::updateAllPredictionsAndCountLiveness(unsigned int&, unsigned int&) + 1814 (SpeculatedType.h:473)
2   com.apple.JavaScriptCore      	0x0000000106fefa6b JSC::CodeBlock::finalizeUnconditionally(JSC::VM&) + 27 (CodeBlock.cpp:2624)
3   com.apple.JavaScriptCore      	0x00000001072da9ea void JSC::IsoCellSet::forEachMarkedCell<void JSC::Heap::finalizeMarkedUnconditionalFinalizers<JSC::CodeBlock, JSC::IsoCellSet>(JSC::IsoCellSet&)::'lambda'(JSC::HeapCell*, JSC::HeapCell::Kind)>(void JSC::Heap::finalizeMarkedUnconditionalFinalizers<JSC::CodeBlock, JSC::IsoCellSet>(JSC::IsoCellSet&)::'lambda'(JSC::HeapCell*, JSC::HeapCell::Kind) const&) + 330 (MarkedBlockInlines.h:540)
4   com.apple.JavaScriptCore      	0x00000001072d1518 JSC::Heap::finalizeUnconditionalFinalizers() + 104 (Heap.cpp:593)
5   com.apple.JavaScriptCore      	0x00000001072d5995 JSC::Heap::runEndPhase(JSC::GCConductor) + 1653 (Heap.cpp:702)
6   com.apple.JavaScriptCore      	0x00000001072d3c6f JSC::Heap::runCurrentPhase(JSC::GCConductor, JSC::CurrentThreadState*) + 239 (Heap.cpp:1191)
7   com.apple.JavaScriptCore      	0x00000001072dce3b WTF::ScopedLambdaFunctor<void (JSC::CurrentThreadState&), JSC::Heap::collectInMutatorThread()::$_0>::implFunction(void*, JSC::CurrentThreadState&) + 27 (Heap.cpp:1791)
8   com.apple.JavaScriptCore      	0x00000001072ef3e5 JSC::callWithCurrentThreadState(WTF::ScopedLambda<void (JSC::CurrentThreadState&)> const&) + 117 (MachineStackMarker.cpp:226)
9   com.apple.JavaScriptCore      	0x00000001072d750d JSC::Heap::collectInMutatorThread() + 93 (CollectingScope.h:43)
10  com.apple.JavaScriptCore      	0x00000001072d73d5 JSC::Heap::stopIfNecessarySlow(unsigned int) + 53 (Heap.cpp:1771)
11  com.apple.JavaScriptCore      	0x00000001072d72cf JSC::Heap::stopIfNecessarySlow() + 47 (Heap.cpp:1745)
12  com.apple.JavaScriptCore      	0x00000001072d0ee4 JSC::Heap::collectIfNecessaryOrDefer(JSC::GCDeferralContext*) + 132 (Heap.cpp:2566)
13  com.apple.JavaScriptCore      	0x000000010772fe67 JSC::Structure::materializePropertyTable(JSC::VM&, bool) + 1015 (HeapInlines.h:195)
14  com.apple.JavaScriptCore      	0x00000001077332d9 JSC::Structure::getPropertyNamesFromStructure(JSC::VM&, JSC::PropertyNameArray&, JSC::EnumerationMode) + 1097 (Structure.h:727)
15  com.apple.JavaScriptCore      	0x000000010765ff3a JSC::JSObject::getOwnNonIndexPropertyNames(JSC::JSObject*, JSC::ExecState*, JSC::PropertyNameArray&, JSC::EnumerationMode) + 1066 (JSObject.cpp:2369)
16  com.apple.JavaScriptCore      	0x000000010765f835 JSC::JSObject::getOwnPropertyNames(JSC::JSObject*, JSC::ExecState*, JSC::PropertyNameArray&, JSC::EnumerationMode) + 117 (JSObject.cpp:2357)
17  com.apple.WebCore             	0x000000010a4e79f7 WebCore::CloneSerializer::serialize(JSC::JSValue) + 4695 (SerializedScriptValue.cpp:1561)
18  com.apple.WebCore             	0x000000010a4eed00 WebCore::SerializedScriptValue::create(JSC::ExecState&, JSC::JSValue, WTF::Vector<JSC::Strong<JSC::JSObject>, 0ul, WTF::CrashOnOverflow, 16ul>&&, WTF::Vector<WTF::RefPtr<WebCore::MessagePort, WTF::DumbPtrTraits<WebCore::MessagePort> >, 0ul, WTF::CrashOnOverflow, 16ul>&, WebCore::SerializationContext) + 1536 (SerializedScriptValue.cpp:557)
19  com.apple.WebCore             	0x000000010b0f4199 WebCore::DedicatedWorkerGlobalScope::postMessage(JSC::ExecState&, JSC::JSValue, WTF::Vector<JSC::Strong<JSC::JSObject>, 0ul, WTF::CrashOnOverflow, 16ul>&&) + 57 (DedicatedWorkerGlobalScope.cpp:69)
20  com.apple.WebCore             	0x0000000109e115c0 WebCore::jsDedicatedWorkerGlobalScopeInstanceFunctionPostMessage(JSC::ExecState*) + 256 (JSDOMExceptionHandling.h:93)

*** This bug has been marked as a duplicate of bug 192050 ***