Bug 192058 - Flaky Test: inspector/unit-tests/cookie.html
Summary: Flaky Test: inspector/unit-tests/cookie.html
Status: RESOLVED DUPLICATE of bug 192050
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: WebKit Commit Bot
URL:
Keywords:
Depends on:
Blocks: 50856
  Show dependency treegraph
 
Reported: 2018-11-27 17:07 PST by WebKit Commit Bot
Modified: 2018-12-01 16:05 PST (History)
4 users (show)

See Also:


Attachments
Archive of layout-test-results from webkit-cq-01 (2.45 MB, application/zip)
2018-11-27 17:07 PST, WebKit Commit Bot
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description WebKit Commit Bot 2018-11-27 17:07:38 PST
This is an automatically generated bug from the commit-queue.
inspector/unit-tests/cookie.html has been flaky on the commit-queue.

inspector/unit-tests/cookie.html was authored by joepeck@webkit.org.
https://trac.webkit.org/browser/trunk/LayoutTests/inspector/unit-tests/cookie.html

The commit-queue just saw inspector/unit-tests/cookie.html flake (DumpRenderTree crashed) while processing attachment 355813 [details] on bug 192053.
Bot: webkit-cq-01  Port: <class 'webkitpy.common.config.ports.MacPort'>  Platform: Mac OS X 10.12.6

The bots will update this with information from each new failure.

If you believe this bug to be fixed or invalid, feel free to close.  The bots will re-open if the flake re-occurs.

If you would like to track this test fix with another bug, please close this bug as a duplicate.  The bots will follow the duplicate chain when making future comments.
Comment 1 WebKit Commit Bot 2018-11-27 17:07:39 PST
Created attachment 355826 [details]
Archive of layout-test-results from webkit-cq-01
Comment 2 Ryan Haddad 2018-11-28 09:53:52 PST
Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   com.apple.JavaScriptCore      	0x000000010eda5c55 JSC::speculationFromValue(JSC::JSValue) + 213 (SpeculatedType.cpp:477)
1   com.apple.JavaScriptCore      	0x000000010ed777f6 JSC::CodeBlock::updateAllPredictionsAndCountLiveness(unsigned int&, unsigned int&) + 1814 (SpeculatedType.h:473)
2   com.apple.JavaScriptCore      	0x000000010ed722fb JSC::CodeBlock::finalizeUnconditionally(JSC::VM&) + 27 (CodeBlock.cpp:2624)
3   com.apple.JavaScriptCore      	0x000000010f05ceba void JSC::IsoCellSet::forEachMarkedCell<void JSC::Heap::finalizeMarkedUnconditionalFinalizers<JSC::CodeBlock, JSC::IsoCellSet>(JSC::IsoCellSet&)::'lambda'(JSC::HeapCell*, JSC::HeapCell::Kind)>(void JSC::Heap::finalizeMarkedUnconditionalFinalizers<JSC::CodeBlock, JSC::IsoCellSet>(JSC::IsoCellSet&)::'lambda'(JSC::HeapCell*, JSC::HeapCell::Kind) const&) + 330 (MarkedBlockInlines.h:540)
4   com.apple.JavaScriptCore      	0x000000010f0539e8 JSC::Heap::finalizeUnconditionalFinalizers() + 104 (Heap.cpp:593)
5   com.apple.JavaScriptCore      	0x000000010f057e65 JSC::Heap::runEndPhase(JSC::GCConductor) + 1653 (Heap.cpp:702)
6   com.apple.JavaScriptCore      	0x000000010f05613f JSC::Heap::runCurrentPhase(JSC::GCConductor, JSC::CurrentThreadState*) + 239 (Heap.cpp:1191)
7   com.apple.JavaScriptCore      	0x000000010f05f30b WTF::ScopedLambdaFunctor<void (JSC::CurrentThreadState&), JSC::Heap::collectInMutatorThread()::$_0>::implFunction(void*, JSC::CurrentThreadState&) + 27 (Heap.cpp:1791)
8   com.apple.JavaScriptCore      	0x000000010f0718b5 JSC::callWithCurrentThreadState(WTF::ScopedLambda<void (JSC::CurrentThreadState&)> const&) + 117 (MachineStackMarker.cpp:226)
9   com.apple.JavaScriptCore      	0x000000010f0599dd JSC::Heap::collectInMutatorThread() + 93 (CollectingScope.h:43)
10  com.apple.JavaScriptCore      	0x000000010f0598a5 JSC::Heap::stopIfNecessarySlow(unsigned int) + 53 (Heap.cpp:1771)
11  com.apple.JavaScriptCore      	0x000000010f05979f JSC::Heap::stopIfNecessarySlow() + 47 (Heap.cpp:1745)
12  com.apple.JavaScriptCore      	0x000000010f3fe5f9 JSC::JSRunLoopTimer::timerDidFire() + 89 (atomic:936)
13  com.apple.JavaScriptCore      	0x000000010f3fe138 JSC::JSRunLoopTimer::Manager::timerDidFire() + 904 (JSRunLoopTimer.cpp:159)
14  com.apple.CoreFoundation      	0x00007fffa9ebde04 __CFRUNLOOP_IS_CALLING_OUT_TO_A_TIMER_CALLBACK_FUNCTION__ + 20
15  com.apple.CoreFoundation      	0x00007fffa9ebda93 __CFRunLoopDoTimer + 1075
16  com.apple.CoreFoundation      	0x00007fffa9ebd5ea __CFRunLoopDoTimers + 298
17  com.apple.CoreFoundation      	0x00007fffa9eb4fc1 __CFRunLoopRun + 2081
18  com.apple.CoreFoundation      	0x00007fffa9eb4544 CFRunLoopRunSpecific + 420
19  DumpRenderTree                	0x000000010e6e06f5 runTest(std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char> > const&) + 2821 (DumpRenderTree.mm:2063)
20  DumpRenderTree                	0x000000010e6df86a dumpRenderTree(int, char const**) + 3129 (DumpRenderTree.mm:1194)
21  DumpRenderTree                	0x000000010e6e111b DumpRenderTreeMain(int, char const**) + 1456 (DumpRenderTree.mm:1426)
22  libdyld.dylib                 	0x00007fffbfa7d235 start + 1
Comment 3 Alexey Proskuryakov 2018-12-01 16:05:35 PST

*** This bug has been marked as a duplicate of bug 192050 ***